Read the docs
TI-2017-02360 Aliases CVE-2017-3140GHSA-6f7c-h629-3xqv

An error processing RPZ rules can cause named to loop endlessly after handling a query

Priority MEDIUM 40CWE-400Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
No fix listed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-400.

Summary

If named is configured to use Response Policy Zones (RPZ) an error processing some rule types can lead to a condition where BIND will endlessly loop while handling a query. Affects BIND 9.9.10, 9.10.5, 9.11.0->9.11.1, 9.9.10-S1, 9.10.5-S1.

Why it matters now

EPSS 0.12184 96th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCBIND 99.9.10, 9.10.5, 9.11.0->9.11.1, 9.9.10-S1, 9.10.5-S1—No fix listedCNA
  • BIND 9 VendorISC Affected 9.9.10, 9.10.5, 9.11.0->9.11.1, 9.9.10-S1, 9.10.5-S1 Fixed in — No fix listed CNA

CPE configurations NVD · 8

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:*9.11.0 – 9.11.1VulnerableISC
cpe:2.3:a:isc:bind:9.9.10:*:*:*:*:*:*:*9.9.10VulnerableISC
cpe:2.3:a:isc:bind:9.9.10:s1:*:*:*:*:*:*9.9.10 s1VulnerableISC
cpe:2.3:a:isc:bind:9.10.5:*:*:*:*:*:*:*9.10.5VulnerableISC
cpe:2.3:a:isc:bind:9.10.5:s1:*:*:*:*:*:*9.10.5 s1VulnerableISC
cpe:2.3:a:netapp:data_ontap_edge:-:*:*:*:*:*:*:*not specified by NVDVulnerableNetApp
cpe:2.3:a:netapp:element_software:-:*:*:*:*:*:*:*not specified by NVDVulnerableNetApp
cpe:2.3:a:netapp:oncommand_balance:-:*:*:*:*:*:*:*not specified by NVDVulnerableNetApp
  • cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:* Versions 9.11.0 – 9.11.1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.10:*:*:*:*:*:*:* Versions 9.9.10 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.10:s1:*:*:*:*:*:* Versions 9.9.10 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.5:*:*:*:*:*:*:* Versions 9.10.5 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.5:s1:*:*:*:*:*:* Versions 9.10.5 s1 Vulnerable ·ISC
  • cpe:2.3:a:netapp:data_ontap_edge:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
  • cpe:2.3:a:netapp:element_software:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
  • cpe:2.3:a:netapp:oncommand_balance:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp

Remediation

No fixed version listed by the sources yet.

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 3 products
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-3140
  2. 2026-10-03 Alias added: GHSA-6f7c-h629-3xqv

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources