Out-of-bounds write in Google Chrome prior to 57.0.2987.98 for Mac, Windows and Linux…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-787 and the CVSS impact.
Summary
The xsltAddTextString function in transform.c in libxslt 1.1.29, as used in Blink in Google Chrome prior to 57.0.2987.98 for Mac, Windows, and Linux and 57.0.2987.108 for Android, lacked a check for integer overflow during a size calculation, which allowed a remote attacker to perform an out of bounds memory write via a crafted HTML page.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Google Chrome prior to 57.0.2987.98 for Mac, Windows and Linux, and 57.0.2987.108 for Android | Google Chrome prior to 57.0.2987.98 for Mac, Windows and Linux, and 57.0.2987.108 for Android | — | No fix listed | CNA |
| — | nokogiri (RubyGems) | before 1.7.2 | 1.7.2 | Patch available | GHSA-pf6m-fxpq-fg8v |
- Google Chrome prior to 57.0.2987.98 for Mac, Windows and Linux, and 57.0.2987.108 for Android Vendor— Affected Google Chrome prior to 57.0.2987.98 for Mac, Windows and Linux, and 57.0.2987.108 for Android Fixed in — No fix listed CNA
- nokogiri (RubyGems) Vendor— Affected before 1.7.2 Fixed in 1.7.2 Patch available GHSA-pf6m-fxpq-fg8v
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* | up to 57.0.2987.75 | Vulnerable | |
| cpe:2.3:o:apple:macos:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Apple |
| cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Linux |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
| cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* | up to 57.0.2987.100 | Vulnerable | |
| cpe:2.3:o:google:android:-:*:*:*:*:*:*:* | not specified by NVD | Running on | |
| cpe:2.3:a:xmlsoft:libxslt:1.1.29:*:*:*:*:*:*:* | 1.1.29 | Vulnerable | xmlsoft |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:redhat:enterprise_linux_desktop:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
- cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* Versions up to 57.0.2987.75 Vulnerable ·Google
- cpe:2.3:o:apple:macos:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Apple
- cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Linux
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
- cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* Versions up to 57.0.2987.100 Vulnerable ·Google
- cpe:2.3:o:google:android:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Google
- cpe:2.3:a:xmlsoft:libxslt:1.1.29:*:*:*:*:*:*:* Versions 1.1.29 Vulnerable ·xmlsoft
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:redhat:enterprise_linux_desktop:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
Remediation
- Fix · GHSA-pf6m-fxpq-fg8v nokogiri (RubyGems) Fixed in 1.7.2 Advisory →
Red Hat 1 advisory
- RHSA-2017:0499 Released 2017-03-14 · Red Hat rating Importantchromium-browser security update
- Red Hat Enterprise Linux Desktop Supplementary (v. 6) chromium-browser-57.0.2987.98-1.el6
- Red Hat Enterprise Linux Server Supplementary (v. 6) chromium-browser-57.0.2987.98-1.el6
- Red Hat Enterprise Linux Workstation Supplementary (v. 6) chromium-browser-57.0.2987.98-1.el6
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Google Chrome prior to 57.0.2987.98 for Mac, Windows and Linux, and 57.0.2987.108 for Android — RHSA-2017:0499
10 records Highest priority Priority MEDIUM 2 MEDIUM, 8 LOW
Other records, highest priority first
- TI-2017-03162 V8 in Google Chrome prior to 57.0.2987.98 for Mac, Windows, and Linux and 57.0.2987.108…Priority MEDIUM 42
- TI-2017-03161 Use after free in Google Chrome prior to 57.0.2987.98 for Mac, Windows and Linux, and…Priority LOW 37
- TI-2017-03159 Integer overflow in Google Chrome prior to 57.0.2987.98 for Mac, Windows and Linux, and…Priority LOW 36
- Advisory ·
Google Chrome prior to 57.0.2987.98 for Mac, Windows and Linux, and 57.0.2987.108 for Android — DSA-3810
10 records Highest priority Priority MEDIUM 2 MEDIUM, 8 LOW
Other records, highest priority first
- TI-2017-03162 V8 in Google Chrome prior to 57.0.2987.98 for Mac, Windows, and Linux and 57.0.2987.108…Priority MEDIUM 42
- TI-2017-03161 Use after free in Google Chrome prior to 57.0.2987.98 for Mac, Windows and Linux, and…Priority LOW 37
- TI-2017-03159 Integer overflow in Google Chrome prior to 57.0.2987.98 for Mac, Windows and Linux, and…Priority LOW 36
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux Desktop Supplementary (v. 6) | Fixed | RHSA-2017:0499 |
| Red Hat Enterprise Linux Server Supplementary (v. 6) | Fixed | RHSA-2017:0499 |
| Red Hat Enterprise Linux Workstation Supplementary (v. 6) | Fixed | RHSA-2017:0499 |
Timeline
- 2026-10-02 Threatist record created from CVE-2017-5029
- 2026-10-03 Alias added: GHSA-pf6m-fxpq-fg8v
References
Advisory 4
Other 8
- https://chromereleases.googleblog.com/2017/03/stable-channel-update-for-desktop.html
- https://git.gnome.org/browse/libxslt/commit/?id=08ab2774b870de1c7b5a48693df75e8154addae5
- https://crbug.com/676623
- https://github.com/sparklemotion/nokogiri/issues/1634
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/CVE-2017-5029.yml
- https://github.com/sparklemotion/nokogiri
- https://ubuntu.com/security/CVE-2017-5029
- https://ubuntu.com/security/notices/USN-3271-1
Sources
- CVE-2017-5029 · CVE Program
- CVE-2017-5029 · NVD
- FIRST EPSS
- GHSA-pf6m-fxpq-fg8v · GitHub Advisory Database · CC BY 4.0
- CVE-2017-5029 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences