Integer overflow in Debian icoutils
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-190 and the CVSS impact.
Summary
Integer overflow in the check_offset function in b/wrestool/fileread.c in icoutils before 0.31.1 allows local users to cause a denial of service (process crash) and execute arbitrary code via a crafted executable.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Debian | icoutils | before 0.31.1 | 0.31.1 | Patch available | CNA |
- icoutils VendorDebian Affected before 0.31.1 Fixed in 0.31.1 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:icoutils_project:icoutils:*:*:*:*:*:*:*:* | before 0.31.1 | Vulnerable | Icoutils Project |
| cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:* | 12.04 | Vulnerable | Canonical |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:opensuse:leap:42.1:*:*:*:*:*:*:* | 42.1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:42.2:*:*:*:*:*:*:* | 42.2 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:* | 13.2 | Vulnerable | openSUSE |
- cpe:2.3:a:icoutils_project:icoutils:*:*:*:*:*:*:*:* Versions before 0.31.1 Vulnerable ·Icoutils Project
- cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:* Versions 12.04 Vulnerable ·Canonical
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:opensuse:leap:42.1:*:*:*:*:*:*:* Versions 42.1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:42.2:*:*:*:*:*:*:* Versions 42.2 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:* Versions 13.2 Vulnerable ·openSUSE
Remediation
- Fix · CNA icoutils (Debian) Fixed in 0.31.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Debian icoutils — openSUSE-SU-2017:0166
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2017-03377 Integer overflow in Debian icoutilsPriority LOW 38
- TI-2017-03376 Memory corruption in Debian icoutilsPriority LOW 38
- Advisory ·
Debian icoutils — openSUSE-SU-2017:0167
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2017-03377 Integer overflow in Debian icoutilsPriority LOW 38
- TI-2017-03376 Memory corruption in Debian icoutilsPriority LOW 38
Show 3 more groups
- Advisory ·
Debian icoutils — openSUSE-SU-2017:0168
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2017-03377 Integer overflow in Debian icoutilsPriority LOW 38
- TI-2017-03376 Memory corruption in Debian icoutilsPriority LOW 38
- Advisory ·
Debian icoutils — DSA-3765
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2017-03377 Integer overflow in Debian icoutilsPriority LOW 38
- TI-2017-03376 Memory corruption in Debian icoutilsPriority LOW 38
- Advisory ·
Debian icoutils — USN-3178-1
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2017-03377 Integer overflow in Debian icoutilsPriority LOW 38
- TI-2017-03376 Memory corruption in Debian icoutilsPriority LOW 38
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2017-5331
- 2026-10-03 Alias added: GHSA-pp7c-cq7m-4vmc
References
More Debian Linux vulnerabilities
- TI-2026-19388 telnetd in GNU Inetutils through 2.7 allows remote authentication bypass via a "-f root"… KEVCVSS 3.1CRITICAL 9.8
- TI-2025-31204 Deserialization of untrusted data in Roundcube Webmail KEVCVSS 3.1CRITICAL 9.9
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2025-23504 Erlang/OTP SSH Vulnerable to Pre-Authentication RCE KEVCVSS 3.1CRITICAL 10.0
- TI-2025-18529 Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT KEVCVSS 3.1CRITICAL 10.0
- TI-2025-17951 Out-of-bounds write in Apple Safari KEVCVSS 3.1CRITICAL 10.0
Sources
- CVE-2017-5331 · CVE Program
- CVE-2017-5331 · NVD
- FIRST EPSS
- GHSA-pp7c-cq7m-4vmc · GitHub Advisory Database · CC BY 4.0
- CVE-2017-5331 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences