Double free vulnerability in the gnutls_x509_ext_import_proxy function in GnuTLS before…
Priority HIGH 67CWE-415Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-415 and the CVSS impact.
Summary
Double free vulnerability in the gnutls_x509_ext_import_proxy function in GnuTLS before 3.3.26 and 3.5.x before 3.5.8 allows remote attackers to have unspecified impact via crafted policy language information in an X.509 certificate with a Proxy Certificate Information extension.
Why it matters now
EPSS 0.32754 98th percentileScored 2026-11-07
Fix Fixed Red Hat: 1 advisory
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 11
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:opensuse:leap:42.1:*:*:*:*:*:*:* | 42.1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:42.2:*:*:*:*:*:*:* | 42.2 | Vulnerable | openSUSE |
| cpe:2.3:a:gnu:gnutls:*:*:*:*:*:*:*:* | up to 3.3.25 | Vulnerable | GNU |
| cpe:2.3:a:gnu:gnutls:3.5.0:*:*:*:*:*:*:* | 3.5.0 | Vulnerable | GNU |
| cpe:2.3:a:gnu:gnutls:3.5.1:*:*:*:*:*:*:* | 3.5.1 | Vulnerable | GNU |
| cpe:2.3:a:gnu:gnutls:3.5.2:*:*:*:*:*:*:* | 3.5.2 | Vulnerable | GNU |
| cpe:2.3:a:gnu:gnutls:3.5.3:*:*:*:*:*:*:* | 3.5.3 | Vulnerable | GNU |
| cpe:2.3:a:gnu:gnutls:3.5.4:*:*:*:*:*:*:* | 3.5.4 | Vulnerable | GNU |
| cpe:2.3:a:gnu:gnutls:3.5.5:*:*:*:*:*:*:* | 3.5.5 | Vulnerable | GNU |
| cpe:2.3:a:gnu:gnutls:3.5.6:*:*:*:*:*:*:* | 3.5.6 | Vulnerable | GNU |
- cpe:2.3:o:opensuse:leap:42.1:*:*:*:*:*:*:* Versions 42.1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:42.2:*:*:*:*:*:*:* Versions 42.2 Vulnerable ·openSUSE
- cpe:2.3:a:gnu:gnutls:*:*:*:*:*:*:*:* Versions up to 3.3.25 Vulnerable ·GNU
- cpe:2.3:a:gnu:gnutls:3.5.0:*:*:*:*:*:*:* Versions 3.5.0 Vulnerable ·GNU
- cpe:2.3:a:gnu:gnutls:3.5.1:*:*:*:*:*:*:* Versions 3.5.1 Vulnerable ·GNU
- cpe:2.3:a:gnu:gnutls:3.5.2:*:*:*:*:*:*:* Versions 3.5.2 Vulnerable ·GNU
- cpe:2.3:a:gnu:gnutls:3.5.3:*:*:*:*:*:*:* Versions 3.5.3 Vulnerable ·GNU
- cpe:2.3:a:gnu:gnutls:3.5.4:*:*:*:*:*:*:* Versions 3.5.4 Vulnerable ·GNU
- cpe:2.3:a:gnu:gnutls:3.5.5:*:*:*:*:*:*:* Versions 3.5.5 Vulnerable ·GNU
- cpe:2.3:a:gnu:gnutls:3.5.6:*:*:*:*:*:*:* Versions 3.5.6 Vulnerable ·GNU
Remediation
Red Hat 1 advisory
- RHSA-2017:2292 Released 2017-08-01 · Red Hat rating Moderategnutls security, bug fix, and enhancement update
- Red Hat Enterprise Linux Client (v. 7) gnutls-3.3.26-9.el7, gnutls-dane-3.3.26-9.el7, gnutls-utils-3.3.26-9.el7
- Red Hat Enterprise Linux Client Optional (v. 7) gnutls-c++-3.3.26-9.el7, gnutls-devel-3.3.26-9.el7
- Red Hat Enterprise Linux ComputeNode (v. 7) gnutls-3.3.26-9.el7, gnutls-dane-3.3.26-9.el7, gnutls-utils-3.3.26-9.el7
- Red Hat Enterprise Linux ComputeNode Optional (v. 7) gnutls-c++-3.3.26-9.el7, gnutls-devel-3.3.26-9.el7
- Red Hat Enterprise Linux Server (v. 7) gnutls-3.3.26-9.el7, gnutls-3.3.26-9.el7.ppc, gnutls-c++-3.3.26-9.el7 +6
- Red Hat Enterprise Linux Workstation (v. 7) gnutls-3.3.26-9.el7, gnutls-c++-3.3.26-9.el7, gnutls-dane-3.3.26-9.el7 +2
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux Client (v. 7) | Fixed | RHSA-2017:2292 |
| Red Hat Enterprise Linux Client Optional (v. 7) | Fixed | RHSA-2017:2292 |
| Red Hat Enterprise Linux ComputeNode (v. 7) | Fixed | RHSA-2017:2292 |
| Red Hat Enterprise Linux ComputeNode Optional (v. 7) | Fixed | RHSA-2017:2292 |
| Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2017:2292 |
| Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2017:2292 |
Not affected: 2 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
Timeline
- 2026-10-02 Threatist record created from CVE-2017-5334
- 2026-10-03 Alias added: GHSA-xwcr-3xw9-7333
References
Patch 4
- [oss-security] 20170110 CVE request: two advisories for GnuTLS GNUTLS-SA-2017-1, GNUTLS-SA-2017-2, fixed in 3.3.26, 3.5.8
- [oss-security] 20170110 Re: CVE request: two advisories for GnuTLS GNUTLS-SA-2017-1, GNUTLS-SA-2017-2, fixed in 3.3.26, 3.5.8
- GLSA-201702-04
- https://gitlab.com/gnutls/gnutls/commit/c5aaa488a3d6df712dc8dff23a049133cab5ec1b
Sources
- CVE-2017-5334 · CVE Program
- CVE-2017-5334 · NVD
- FIRST EPSS
- GHSA-xwcr-3xw9-7333 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-5334 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences