The stream reading functions in lib/opencdk/read-packet.c in GnuTLS before 3.3.26 and…
Priority MEDIUM 44CWE-125Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 14 fixed, 1 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-125 and the CVSS impact.
Summary
The stream reading functions in lib/opencdk/read-packet.c in GnuTLS before 3.3.26 and 3.5.x before 3.5.8 allow remote attackers to cause a denial of service (out-of-memory error and crash) via a crafted OpenPGP certificate.
Why it matters now
EPSS 0.08009 94th percentileScored 2026-11-07
Fix Partial Red Hat: 2 advisoriesRed Hat: 14 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 11
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:opensuse:leap:42.1:*:*:*:*:*:*:* | 42.1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:42.2:*:*:*:*:*:*:* | 42.2 | Vulnerable | openSUSE |
| cpe:2.3:a:gnu:gnutls:*:*:*:*:*:*:*:* | up to 3.3.25 | Vulnerable | GNU |
| cpe:2.3:a:gnu:gnutls:3.5.0:*:*:*:*:*:*:* | 3.5.0 | Vulnerable | GNU |
| cpe:2.3:a:gnu:gnutls:3.5.1:*:*:*:*:*:*:* | 3.5.1 | Vulnerable | GNU |
| cpe:2.3:a:gnu:gnutls:3.5.2:*:*:*:*:*:*:* | 3.5.2 | Vulnerable | GNU |
| cpe:2.3:a:gnu:gnutls:3.5.3:*:*:*:*:*:*:* | 3.5.3 | Vulnerable | GNU |
| cpe:2.3:a:gnu:gnutls:3.5.4:*:*:*:*:*:*:* | 3.5.4 | Vulnerable | GNU |
| cpe:2.3:a:gnu:gnutls:3.5.5:*:*:*:*:*:*:* | 3.5.5 | Vulnerable | GNU |
| cpe:2.3:a:gnu:gnutls:3.5.6:*:*:*:*:*:*:* | 3.5.6 | Vulnerable | GNU |
- cpe:2.3:o:opensuse:leap:42.1:*:*:*:*:*:*:* Versions 42.1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:42.2:*:*:*:*:*:*:* Versions 42.2 Vulnerable ·openSUSE
- cpe:2.3:a:gnu:gnutls:*:*:*:*:*:*:*:* Versions up to 3.3.25 Vulnerable ·GNU
- cpe:2.3:a:gnu:gnutls:3.5.0:*:*:*:*:*:*:* Versions 3.5.0 Vulnerable ·GNU
- cpe:2.3:a:gnu:gnutls:3.5.1:*:*:*:*:*:*:* Versions 3.5.1 Vulnerable ·GNU
- cpe:2.3:a:gnu:gnutls:3.5.2:*:*:*:*:*:*:* Versions 3.5.2 Vulnerable ·GNU
- cpe:2.3:a:gnu:gnutls:3.5.3:*:*:*:*:*:*:* Versions 3.5.3 Vulnerable ·GNU
- cpe:2.3:a:gnu:gnutls:3.5.4:*:*:*:*:*:*:* Versions 3.5.4 Vulnerable ·GNU
- cpe:2.3:a:gnu:gnutls:3.5.5:*:*:*:*:*:*:* Versions 3.5.5 Vulnerable ·GNU
- cpe:2.3:a:gnu:gnutls:3.5.6:*:*:*:*:*:*:* Versions 3.5.6 Vulnerable ·GNU
Remediation
Red Hat 2 advisories
- RHSA-2017:2292 Released 2017-08-01 · Red Hat rating Moderategnutls security, bug fix, and enhancement update
- Red Hat Enterprise Linux Client (v. 7) gnutls-3.3.26-9.el7, gnutls-dane-3.3.26-9.el7, gnutls-utils-3.3.26-9.el7
- Red Hat Enterprise Linux Client Optional (v. 7) gnutls-c++-3.3.26-9.el7, gnutls-devel-3.3.26-9.el7
- Red Hat Enterprise Linux ComputeNode (v. 7) gnutls-3.3.26-9.el7, gnutls-dane-3.3.26-9.el7, gnutls-utils-3.3.26-9.el7
- Red Hat Enterprise Linux ComputeNode Optional (v. 7) gnutls-c++-3.3.26-9.el7, gnutls-devel-3.3.26-9.el7
- Red Hat Enterprise Linux Server (v. 7) gnutls-3.3.26-9.el7, gnutls-3.3.26-9.el7.ppc, gnutls-c++-3.3.26-9.el7 +6
- Red Hat Enterprise Linux Workstation (v. 7) gnutls-3.3.26-9.el7, gnutls-c++-3.3.26-9.el7, gnutls-dane-3.3.26-9.el7 +2
- RHSA-2017:0574 Released 2017-03-21 · Red Hat rating Moderategnutls security, bug fix, and enhancement update
- Red Hat Enterprise Linux Desktop (v. 6) gnutls-2.12.23-21.el6, gnutls-utils-2.12.23-21.el6
- Red Hat Enterprise Linux Desktop Optional (v. 6) gnutls-devel-2.12.23-21.el6, gnutls-guile-2.12.23-21.el6
- Red Hat Enterprise Linux HPC Node (v. 6) gnutls-2.12.23-21.el6, gnutls-utils-2.12.23-21.el6
- Red Hat Enterprise Linux HPC Node Optional (v. 6) gnutls-devel-2.12.23-21.el6, gnutls-guile-2.12.23-21.el6
- Red Hat Enterprise Linux Server (v. 6) gnutls-2.12.23-21.el6, gnutls-2.12.23-21.el6.ppc, gnutls-devel-2.12.23-21.el6 +2
- Red Hat Enterprise Linux Server Optional (v. 6) gnutls-guile-2.12.23-21.el6, gnutls-guile-2.12.23-21.el6.ppc
- Red Hat Enterprise Linux Workstation (v. 6) gnutls-2.12.23-21.el6, gnutls-devel-2.12.23-21.el6, gnutls-utils-2.12.23-21.el6
- Red Hat Enterprise Linux Workstation Optional (v. 6) gnutls-guile-2.12.23-21.el6
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux Client (v. 7) | Fixed | RHSA-2017:2292 |
| Red Hat Enterprise Linux Client Optional (v. 7) | Fixed | RHSA-2017:2292 |
| Red Hat Enterprise Linux ComputeNode (v. 7) | Fixed | RHSA-2017:2292 |
| Red Hat Enterprise Linux ComputeNode Optional (v. 7) | Fixed | RHSA-2017:2292 |
| Red Hat Enterprise Linux Desktop (v. 6) | Fixed | RHSA-2017:0574 |
| Red Hat Enterprise Linux Desktop Optional (v. 6) | Fixed | RHSA-2017:0574 |
| Red Hat Enterprise Linux HPC Node (v. 6) | Fixed | RHSA-2017:0574 |
| Red Hat Enterprise Linux HPC Node Optional (v. 6) | Fixed | RHSA-2017:0574 |
| Red Hat Enterprise Linux Server (v. 6) | Fixed | RHSA-2017:0574 |
| Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2017:2292 |
| Red Hat Enterprise Linux Server Optional (v. 6) | Fixed | RHSA-2017:0574 |
| Red Hat Enterprise Linux Workstation (v. 6) | Fixed | RHSA-2017:0574 |
| Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2017:2292 |
| Red Hat Enterprise Linux Workstation Optional (v. 6) | Fixed | RHSA-2017:0574 |
Timeline
- 2026-10-02 Threatist record created from CVE-2017-5335
- 2026-10-03 Alias added: GHSA-3wcr-vccv-4fcx
References
Patch 5
- [oss-security] 20170110 CVE request: two advisories for GnuTLS GNUTLS-SA-2017-1, GNUTLS-SA-2017-2, fixed in 3.3.26, 3.5.8
- [oss-security] 20170110 Re: CVE request: two advisories for GnuTLS GNUTLS-SA-2017-1, GNUTLS-SA-2017-2, fixed in 3.3.26, 3.5.8
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=337
- GLSA-201702-04
- https://gitlab.com/gnutls/gnutls/commit/49be4f7b82eba2363bb8d4090950dad976a77a3a
Sources
- CVE-2017-5335 · CVE Program
- CVE-2017-5335 · NVD
- FIRST EPSS
- GHSA-3wcr-vccv-4fcx · GitHub Advisory Database · CC BY 4.0
- CVE-2017-5335 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences