Injection in Apache NiFi
Priority MEDIUM 48CWE-74Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
In Apache NiFi before 0.7.2 and 1.x before 1.1.2 in a cluster environment, the proxy chain serialization/deserialization is vulnerable to an injection attack where a carefully crafted username could impersonate another user and gain their permissions on a replicated request to another node.
Why it matters now
EPSS 0.03599 89th percentileScored 2026-11-07
Fix Fixed org.apache.nifi:nifi (Maven): 0.7.2, 1.1.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache NiFi | 0.7.0; 0.7.1; 1.1.0; 1.1.1 | — | No fix listed | CNA |
| — | org.apache.nifi:nifi (Maven) | before 0.7.2 | 0.7.2 | Patch available | GHSA-jrcc-7jf5-3pxg |
| — | org.apache.nifi:nifi (Maven) | 1.0.0 to before 1.1.2 | 1.1.2 | Patch available | GHSA-jrcc-7jf5-3pxg |
- Apache NiFi VendorApache Affected 0.7.0; 0.7.1; 1.1.0; 1.1.1 Fixed in — No fix listed CNA
- org.apache.nifi:nifi (Maven) Vendor— Affected before 0.7.2 Fixed in 0.7.2 Patch available GHSA-jrcc-7jf5-3pxg
- org.apache.nifi:nifi (Maven) Vendor— Affected 1.0.0 to before 1.1.2 Fixed in 1.1.2 Patch available GHSA-jrcc-7jf5-3pxg
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:nifi:0.7.0:*:*:*:*:*:*:* | 0.7.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:0.7.1:*:*:*:*:*:*:* | 0.7.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:1.1.0:*:*:*:*:*:*:* | 1.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:1.1.1:*:*:*:*:*:*:* | 1.1.1 | Vulnerable | Apache |
- cpe:2.3:a:apache:nifi:0.7.0:*:*:*:*:*:*:* Versions 0.7.0 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:0.7.1:*:*:*:*:*:*:* Versions 0.7.1 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:1.1.0:*:*:*:*:*:*:* Versions 1.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:1.1.1:*:*:*:*:*:*:* Versions 1.1.1 Vulnerable ·Apache
Remediation
- Fix · GHSA-jrcc-7jf5-3pxg org.apache.nifi:nifi (Maven) Fixed in 0.7.2 Advisory →
- Fix · GHSA-jrcc-7jf5-3pxg org.apache.nifi:nifi (Maven) Fixed in 1.1.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-5636
- 2026-10-03 Alias added: GHSA-jrcc-7jf5-3pxg
References
More Apache Nifi vulnerabilities
- TI-2023-17293 Apache NiFi: Potential Code Injection with Database Services using H2 CVSS 3.1HIGH 8.8
- TI-2020-16549 Uncontrolled resource consumption in Eclipse Jetty CVSS 3.1MEDIUM 5.3
- TI-2019-07411 Deserialization of untrusted data in Apache Commons Beanutils CVSS 3.1HIGH 7.3
- TI-2017-11471 Improper input validation in Apache NiFi CVSS 3.0CRITICAL 9.8
- TI-2018-01212 XML external entity injection in Apache NiFi CVSS 3.0CRITICAL 9.8
- TI-2021-03489 Deserialization of untrusted data in jackson-databind CVSS 3.1HIGH 8.1
Sources
- CVE-2017-5636 · CVE Program
- CVE-2017-5636 · NVD
- FIRST EPSS
- GHSA-jrcc-7jf5-3pxg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences