The Zip::File component in the rubyzip gem before 1.2.1 for Ruby has a directory…
Priority MEDIUM 48CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
The Zip::File component in the rubyzip gem before 1.2.1 for Ruby has a directory traversal vulnerability. If a site allows uploading of .zip files, an attacker can upload a malicious file that uses "../" pathname substrings to write arbitrary files to the filesystem.
Why it matters now
EPSS 0.03441 89th percentileScored 2026-11-07
Fix Partial rubyzip (RubyGems): 1.2.1Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | rubyzip (RubyGems) | before 1.2.1 | 1.2.1 | Patch available | GHSA-gcqq-w6gr-h9j9 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- rubyzip (RubyGems) Vendor— Affected before 1.2.1 Fixed in 1.2.1 Patch available GHSA-gcqq-w6gr-h9j9
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rubyzip_project:rubyzip:*:*:*:*:*:ruby:*:* | before 1.2.1 | Vulnerable | Rubyzip Project |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:rubyzip_project:rubyzip:*:*:*:*:*:ruby:*:* Versions before 1.2.1 Vulnerable ·Rubyzip Project
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-gcqq-w6gr-h9j9 rubyzip (RubyGems) Fixed in 1.2.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Quickstart Cloud Installer 1 | Affected | — |
Timeline
- 2026-10-02 Threatist record created from CVE-2017-5946
- 2026-10-03 Alias added: GHSA-gcqq-w6gr-h9j9
References
Advisory 4
Sources
- CVE-2017-5946 · CVE Program
- CVE-2017-5946 · NVD
- FIRST EPSS
- GHSA-gcqq-w6gr-h9j9 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-5946 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences