Cross-site scripting (XSS) vulnerability in GetAuthDetails.html.php in PayPal PHP…
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in GetAuthDetails.html.php in PayPal PHP Merchant SDK (aka merchant-sdk-php) 3.9.1 allows remote attackers to inject arbitrary web script or HTML via the token parameter.
Why it matters now
EPSS 0.01244 69th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed paypal/merchant-sdk-php (Packagist): 3.12.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | paypal/merchant-sdk-php (Packagist) | 3.0.0 to before 3.12.0 | 3.12.0 | Patch available | GHSA-p4g7-wjhq-9r2h |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- paypal/merchant-sdk-php (Packagist) Vendor— Affected 3.0.0 to before 3.12.0 Fixed in 3.12.0 Patch available GHSA-p4g7-wjhq-9r2h
Remediation
- Fix · GHSA-p4g7-wjhq-9r2h paypal/merchant-sdk-php (Packagist) Fixed in 3.12.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-6099
- 2026-10-03 Alias added: GHSA-p4g7-wjhq-9r2h
References
Sources
- CVE-2017-6099 · CVE Program
- CVE-2017-6099 · NVD
- FIRST EPSS
- GHSA-p4g7-wjhq-9r2h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences