A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page…
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page (adm_config_report.php) allows remote attackers to inject arbitrary code through a crafted 'action' parameter. This is fixed in 1.3.8, 2.1.2, and 2.2.2.
Why it matters now
EPSS 0.00929 60th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed mantisbt/mantisbt (Packagist): 1.3.8, 2.1.2, 2.2.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mantisbt/mantisbt (Packagist) | before 1.3.8 | 1.3.8 | Patch available | GHSA-v7qf-22rw-chph |
| — | mantisbt/mantisbt (Packagist) | 2.0.0 to before 2.1.2 | 2.1.2 | Patch available | GHSA-v7qf-22rw-chph |
| — | mantisbt/mantisbt (Packagist) | 2.2.0 to before 2.2.2 | 2.2.2 | Patch available | GHSA-v7qf-22rw-chph |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mantisbt/mantisbt (Packagist) Vendor— Affected before 1.3.8 Fixed in 1.3.8 Patch available GHSA-v7qf-22rw-chph
- mantisbt/mantisbt (Packagist) Vendor— Affected 2.0.0 to before 2.1.2 Fixed in 2.1.2 Patch available GHSA-v7qf-22rw-chph
- mantisbt/mantisbt (Packagist) Vendor— Affected 2.2.0 to before 2.2.2 Fixed in 2.2.2 Patch available GHSA-v7qf-22rw-chph
CPE configurations NVD · 23
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mantisbt:mantisbt:1.3.0:rc2:*:*:*:*:*:* | 1.3.0 rc2 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:1.3.1:*:*:*:*:*:*:* | 1.3.1 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:1.3.2:*:*:*:*:*:*:* | 1.3.2 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:1.3.3:*:*:*:*:*:*:* | 1.3.3 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:1.3.4:*:*:*:*:*:*:* | 1.3.4 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:1.3.5:*:*:*:*:*:*:* | 1.3.5 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:1.3.6:*:*:*:*:*:*:* | 1.3.6 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:1.3.7:*:*:*:*:*:*:* | 1.3.7 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:1.3.8:*:*:*:*:*:*:* | 1.3.8 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:1.3.9:*:*:*:*:*:*:* | 1.3.9 | Vulnerable | mantisbt |
- cpe:2.3:a:mantisbt:mantisbt:1.3.0:rc2:*:*:*:*:*:* Versions 1.3.0 rc2 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:1.3.1:*:*:*:*:*:*:* Versions 1.3.1 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:1.3.2:*:*:*:*:*:*:* Versions 1.3.2 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:1.3.3:*:*:*:*:*:*:* Versions 1.3.3 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:1.3.4:*:*:*:*:*:*:* Versions 1.3.4 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:1.3.5:*:*:*:*:*:*:* Versions 1.3.5 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:1.3.6:*:*:*:*:*:*:* Versions 1.3.6 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:1.3.7:*:*:*:*:*:*:* Versions 1.3.7 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:1.3.8:*:*:*:*:*:*:* Versions 1.3.8 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:1.3.9:*:*:*:*:*:*:* Versions 1.3.9 Vulnerable ·mantisbt
Show 13 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mantisbt:mantisbt:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.0.0:beta1:*:*:*:*:*:* | 2.0.0 beta1 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.0.0:beta2:*:*:*:*:*:* | 2.0.0 beta2 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.0.0:beta3:*:*:*:*:*:* | 2.0.0 beta3 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.0.0:rc1:*:*:*:*:*:* | 2.0.0 rc1 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.0.0:rc2:*:*:*:*:*:* | 2.0.0 rc2 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.1.0:*:*:*:*:*:*:* | 2.1.0 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.1.1:*:*:*:*:*:*:* | 2.1.1 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.1.2:*:*:*:*:*:*:* | 2.1.2 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.1.3:*:*:*:*:*:*:* | 2.1.3 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.2.0:*:*:*:*:*:*:* | 2.2.0 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.2.1:*:*:*:*:*:*:* | 2.2.1 | Vulnerable | mantisbt |
- cpe:2.3:a:mantisbt:mantisbt:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.0.0:beta1:*:*:*:*:*:* Versions 2.0.0 beta1 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.0.0:beta2:*:*:*:*:*:* Versions 2.0.0 beta2 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.0.0:beta3:*:*:*:*:*:* Versions 2.0.0 beta3 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.0.0:rc1:*:*:*:*:*:* Versions 2.0.0 rc1 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.0.0:rc2:*:*:*:*:*:* Versions 2.0.0 rc2 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.1.3:*:*:*:*:*:*:* Versions 2.1.3 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.2.1:*:*:*:*:*:*:* Versions 2.2.1 Vulnerable ·mantisbt
Remediation
- Fix · GHSA-v7qf-22rw-chph mantisbt/mantisbt (Packagist) Fixed in 1.3.8 Advisory →
- Fix · GHSA-v7qf-22rw-chph mantisbt/mantisbt (Packagist) Fixed in 2.1.2 Advisory →
- Fix · GHSA-v7qf-22rw-chph mantisbt/mantisbt (Packagist) Fixed in 2.2.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-6973
- 2026-10-03 Alias added: GHSA-v7qf-22rw-chph
References
More Mantisbt vulnerabilities
- TI-2017-05251 MantisBT through 2.3.0 allows arbitrary password reset and unauthenticated admin access… CVSS 3.1HIGH 8.8
- TI-2014-05966 The XmlImportExport plugin in MantisBT 1.2.17 and earlier allows remote attackers to… CVSS 2.0HIGH 7.5
- TI-2025-38760 MantisBT unauthorized disclosure of private project column configuration CVSS 4.0MEDIUM 5.3
- TI-2017-04981 A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page… CVSS 3.0MEDIUM 4.8
- TI-2019-11797 MantisBT before 1.3.20 and 2.22.1 allows Post Authentication Command Injection, leading to Remote Code Execution. CVSS 3.1HIGH 7.2
- TI-2014-07063 The XML Import/Export plugin in MantisBT 1.2.x does not restrict access, which allows… CVSS 2.0MEDIUM 6.4
Sources
- CVE-2017-6973 · CVE Program
- CVE-2017-6973 · NVD
- FIRST EPSS
- GHSA-v7qf-22rw-chph · GitHub Advisory Database · CC BY 4.0
- CVE-2017-6973 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences