An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1.
Priority MEDIUM 41CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1. A malicious website owner could craft a page that executes arbitrary Python code against any cfscrape user who scrapes that website. This is fixed in 1.8.0.
Why it matters now
EPSS 0.01548 75th percentileScored 2026-11-07
Fix Fixed cfscrape (PyPI): 1.8.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | cfscrape (PyPI) | 1.6.6 to before 1.8.0 | 1.8.0 | Patch available | GHSA-5mc5-5j6c-qmf9 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- cfscrape (PyPI) Vendor— Affected 1.6.6 to before 1.8.0 Fixed in 1.8.0 Patch available GHSA-5mc5-5j6c-qmf9
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cloudflare-scrape_project:cloudflare-scrape:1.6.6:*:*:*:*:*:*:* | 1.6.6 | Vulnerable | Cloudflare-scrape Project |
| cpe:2.3:a:cloudflare-scrape_project:cloudflare-scrape:1.6.7:*:*:*:*:*:*:* | 1.6.7 | Vulnerable | Cloudflare-scrape Project |
| cpe:2.3:a:cloudflare-scrape_project:cloudflare-scrape:1.6.8:*:*:*:*:*:*:* | 1.6.8 | Vulnerable | Cloudflare-scrape Project |
| cpe:2.3:a:cloudflare-scrape_project:cloudflare-scrape:1.7.0:*:*:*:*:*:*:* | 1.7.0 | Vulnerable | Cloudflare-scrape Project |
| cpe:2.3:a:cloudflare-scrape_project:cloudflare-scrape:1.7.1:*:*:*:*:*:*:* | 1.7.1 | Vulnerable | Cloudflare-scrape Project |
- cpe:2.3:a:cloudflare-scrape_project:cloudflare-scrape:1.6.6:*:*:*:*:*:*:* Versions 1.6.6 Vulnerable ·Cloudflare-scrape Project
- cpe:2.3:a:cloudflare-scrape_project:cloudflare-scrape:1.6.7:*:*:*:*:*:*:* Versions 1.6.7 Vulnerable ·Cloudflare-scrape Project
- cpe:2.3:a:cloudflare-scrape_project:cloudflare-scrape:1.6.8:*:*:*:*:*:*:* Versions 1.6.8 Vulnerable ·Cloudflare-scrape Project
- cpe:2.3:a:cloudflare-scrape_project:cloudflare-scrape:1.7.0:*:*:*:*:*:*:* Versions 1.7.0 Vulnerable ·Cloudflare-scrape Project
- cpe:2.3:a:cloudflare-scrape_project:cloudflare-scrape:1.7.1:*:*:*:*:*:*:* Versions 1.7.1 Vulnerable ·Cloudflare-scrape Project
Remediation
- Fix · GHSA-5mc5-5j6c-qmf9 cfscrape (PyPI) Fixed in 1.8.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-7235
- 2026-10-03 Alias added: GHSA-5mc5-5j6c-qmf9
References
Advisory 3
Sources
- CVE-2017-7235 · CVE Program
- CVE-2017-7235 · NVD
- FIRST EPSS
- GHSA-5mc5-5j6c-qmf9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences