Rancher Labs rancher server 1.2.0+ is vulnerable to authenticated users disabling access…
Priority MEDIUM 41Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Rancher Labs rancher server 1.2.0+ is vulnerable to authenticated users disabling access control via an API call. This is fixed in versions rancher/server:v1.2.4, rancher/server:v1.3.5, rancher/server:v1.4.3, and rancher/server:v1.5.3.
Why it matters now
EPSS 0.01489 74th percentileScored 2026-11-07
Fix Fixed github.com/rancher/rancher (Go): 1.5.3, 1.4.3, 1.3.5 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/rancher/rancher (Go) | 1.5.0 to before 1.5.3 | 1.5.3 | Patch available | GHSA-w3x4-9854-95x8 |
| — | github.com/rancher/rancher (Go) | 1.4.0 to before 1.4.3 | 1.4.3 | Patch available | GHSA-w3x4-9854-95x8 |
| — | github.com/rancher/rancher (Go) | 1.3.0 to before 1.3.5 | 1.3.5 | Patch available | GHSA-w3x4-9854-95x8 |
| — | github.com/rancher/rancher (Go) | 1.2.0 to before 1.2.4 | 1.2.4 | Patch available | GHSA-w3x4-9854-95x8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/rancher/rancher (Go) Vendor— Affected 1.5.0 to before 1.5.3 Fixed in 1.5.3 Patch available GHSA-w3x4-9854-95x8
- github.com/rancher/rancher (Go) Vendor— Affected 1.4.0 to before 1.4.3 Fixed in 1.4.3 Patch available GHSA-w3x4-9854-95x8
- github.com/rancher/rancher (Go) Vendor— Affected 1.3.0 to before 1.3.5 Fixed in 1.3.5 Patch available GHSA-w3x4-9854-95x8
- github.com/rancher/rancher (Go) Vendor— Affected 1.2.0 to before 1.2.4 Fixed in 1.2.4 Patch available GHSA-w3x4-9854-95x8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:suse:rancher:*:*:*:*:*:*:*:* | 1.2.0 to before 1.2.4; 1.3.0 to before 1.3.5; 1.4.0 to before 1.4.3; 1.5.0 to before 1.5.3 | Vulnerable | SUSE |
- cpe:2.3:a:suse:rancher:*:*:*:*:*:*:*:* Versions 1.2.0 to before 1.2.4; 1.3.0 to before 1.3.5; 1.4.0 to before 1.4.3; 1.5.0 to before 1.5.3 Vulnerable ·SUSE
Remediation
- Fix · GHSA-w3x4-9854-95x8 github.com/rancher/rancher (Go) Fixed in 1.5.3 Advisory →
- Fix · GHSA-w3x4-9854-95x8 github.com/rancher/rancher (Go) Fixed in 1.4.3 Advisory →
- Fix · GHSA-w3x4-9854-95x8 github.com/rancher/rancher (Go) Fixed in 1.3.5 Advisory →
- Fix · GHSA-w3x4-9854-95x8 github.com/rancher/rancher (Go) Fixed in 1.2.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-7297
- 2026-10-03 Alias added: GHSA-w3x4-9854-95x8
References
More SUSE Rancher vulnerabilities
- TI-2021-14903 Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object CVSS 3.1CRITICAL 9.9
- TI-2022-21489 Rancher: Non-random authentication token CVSS 3.1CRITICAL 9.8
- TI-2019-08380 An issue was discovered that affects the following versions of Rancher: v2.0.0 through… CVSS 3.0CRITICAL 9.8
- TI-2023-08827 Improper privilege management in SUSE Rancher CVSS 3.1CRITICAL 9.9
- TI-2023-08823 Improper privilege management in SUSE Rancher CVSS 3.1CRITICAL 9.9
- TI-2022-21491 Rancher: Exposure of sensitive fields CVSS 3.1CRITICAL 9.9
Sources
- CVE-2017-7297 · CVE Program
- CVE-2017-7297 · NVD
- FIRST EPSS
- GHSA-w3x4-9854-95x8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences