It was found that the Keycloak Node.js adapter 2.5 - 3.0 did not handle invalid tokens…
Priority MEDIUM 47CWE-253Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 fixed, 1 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
It was found that the Keycloak Node.js adapter 2.5 - 3.0 did not handle invalid tokens correctly. An attacker could use this flaw to bypass authentication and gain access to restricted information, or to possibly conduct further attacks.
Why it matters now
EPSS 0.02542 85th percentileScored 2026-11-07
Fix Partial keycloak-connect (npm): 3.1.0keycloak-js (npm): 3.1.0Red Hat: 1 advisoryRed Hat: 1 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Red Hat | Keycloak Node.js adapter | 2.5 - 3.0 | — | No fix listed | CNA |
| — | keycloak-connect (npm) | 2.5.0 to before 3.1.0 | 3.1.0 | Patch available | GHSA-mw35-24gh-f82w |
| — | keycloak-js (npm) | 2.5.0 to before 3.1.0 | 3.1.0 | Patch available | GHSA-mw35-24gh-f82w |
- Keycloak Node.js adapter VendorRed Hat Affected 2.5 - 3.0 Fixed in — No fix listed CNA
- keycloak-connect (npm) Vendor— Affected 2.5.0 to before 3.1.0 Fixed in 3.1.0 Patch available GHSA-mw35-24gh-f82w
- keycloak-js (npm) Vendor— Affected 2.5.0 to before 3.1.0 Fixed in 3.1.0 Patch available GHSA-mw35-24gh-f82w
CPE configurations NVD · 11
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:keycloak:keycloak-nodejs-auth-utils:2.5.0:*:*:*:*:*:*:* | 2.5.0 | Vulnerable | Keycloak |
| cpe:2.3:a:keycloak:keycloak-nodejs-auth-utils:2.5.0:cr1:*:*:*:*:*:* | 2.5.0 cr1 | Vulnerable | Keycloak |
| cpe:2.3:a:keycloak:keycloak-nodejs-auth-utils:2.5.1:*:*:*:*:*:*:* | 2.5.1 | Vulnerable | Keycloak |
| cpe:2.3:a:keycloak:keycloak-nodejs-auth-utils:2.5.2:*:*:*:*:*:*:* | 2.5.2 | Vulnerable | Keycloak |
| cpe:2.3:a:keycloak:keycloak-nodejs-auth-utils:2.5.3:*:*:*:*:*:*:* | 2.5.3 | Vulnerable | Keycloak |
| cpe:2.3:a:keycloak:keycloak-nodejs-auth-utils:2.5.4:*:*:*:*:*:*:* | 2.5.4 | Vulnerable | Keycloak |
| cpe:2.3:a:keycloak:keycloak-nodejs-auth-utils:2.5.5:*:*:*:*:*:*:* | 2.5.5 | Vulnerable | Keycloak |
| cpe:2.3:a:keycloak:keycloak-nodejs-auth-utils:2.5.6:*:*:*:*:*:*:* | 2.5.6 | Vulnerable | Keycloak |
| cpe:2.3:a:keycloak:keycloak-nodejs-auth-utils:2.5.7:*:*:*:*:*:*:* | 2.5.7 | Vulnerable | Keycloak |
| cpe:2.3:a:keycloak:keycloak-nodejs-auth-utils:3.0.0:*:*:*:*:*:*:* | 3.0.0 | Vulnerable | Keycloak |
- cpe:2.3:a:keycloak:keycloak-nodejs-auth-utils:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·Keycloak
- cpe:2.3:a:keycloak:keycloak-nodejs-auth-utils:2.5.0:cr1:*:*:*:*:*:* Versions 2.5.0 cr1 Vulnerable ·Keycloak
- cpe:2.3:a:keycloak:keycloak-nodejs-auth-utils:2.5.1:*:*:*:*:*:*:* Versions 2.5.1 Vulnerable ·Keycloak
- cpe:2.3:a:keycloak:keycloak-nodejs-auth-utils:2.5.2:*:*:*:*:*:*:* Versions 2.5.2 Vulnerable ·Keycloak
- cpe:2.3:a:keycloak:keycloak-nodejs-auth-utils:2.5.3:*:*:*:*:*:*:* Versions 2.5.3 Vulnerable ·Keycloak
- cpe:2.3:a:keycloak:keycloak-nodejs-auth-utils:2.5.4:*:*:*:*:*:*:* Versions 2.5.4 Vulnerable ·Keycloak
- cpe:2.3:a:keycloak:keycloak-nodejs-auth-utils:2.5.5:*:*:*:*:*:*:* Versions 2.5.5 Vulnerable ·Keycloak
- cpe:2.3:a:keycloak:keycloak-nodejs-auth-utils:2.5.6:*:*:*:*:*:*:* Versions 2.5.6 Vulnerable ·Keycloak
- cpe:2.3:a:keycloak:keycloak-nodejs-auth-utils:2.5.7:*:*:*:*:*:*:* Versions 2.5.7 Vulnerable ·Keycloak
- cpe:2.3:a:keycloak:keycloak-nodejs-auth-utils:3.0.0:*:*:*:*:*:*:* Versions 3.0.0 Vulnerable ·Keycloak
Remediation
- Fix · GHSA-mw35-24gh-f82w keycloak-connect (npm) Fixed in 3.1.0 Advisory →
- Fix · GHSA-mw35-24gh-f82w keycloak-js (npm) Fixed in 3.1.0 Advisory →
Red Hat 1 advisory
- RHSA-2017:1203 Released 2017-05-08 · Red Hat rating ImportantRed Hat Single Sign-On Node.js adapter security update
- Red Hat Single Sign-On 7.1
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Single Sign-On 7 | Affected | No fix yet |
| Red Hat Single Sign-On 7.1 | Fixed | RHSA-2017:1203 |
Timeline
- 2026-10-02 Threatist record created from CVE-2017-7474
- 2026-10-03 Alias added: GHSA-mw35-24gh-f82w
References
More Red Hat vulnerabilities
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-05363 Code injection in Elastic Kibana KEVCVSS 3.1CRITICAL 10.0
- TI-2019-03949 Out-of-bounds write in ESXi and Horizon DaaS KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2017-7474 · CVE Program
- CVE-2017-7474 · NVD
- FIRST EPSS
- GHSA-mw35-24gh-f82w · GitHub Advisory Database · CC BY 4.0
- CVE-2017-7474 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences