Reachable assertion in openvpn
Priority LOW 33CWE-617Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-617.
Summary
OpenVPN versions before 2.3.15 and before 2.4.2 are vulnerable to reachable assertion when packet-ID counter rolls over resulting into Denial of Service of server by authenticated attacker.
Why it matters now
EPSS 0.01852 79th percentileScored 2026-11-07
Fix Fixed openvpn (OpenVPN Technologies, Inc): 2.3.15, 2.4.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenVPN | openvpn | before 2.3.15; before 2.4.2 | 2.3.15, 2.4.2 | Patch available | CNA |
- openvpn VendorOpenVPN Affected before 2.3.15; before 2.4.2 Fixed in 2.3.15, 2.4.2 Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openvpn:openvpn:*:*:*:*:*:*:*:* | up to 2.3.14 | Vulnerable | OpenVPN |
| cpe:2.3:a:openvpn:openvpn:2.4.0:*:*:*:*:*:*:* | 2.4.0 | Vulnerable | OpenVPN |
| cpe:2.3:a:openvpn:openvpn:2.4.0:alpha2:*:*:*:*:*:* | 2.4.0 alpha2 | Vulnerable | OpenVPN |
| cpe:2.3:a:openvpn:openvpn:2.4.0:beta1:*:*:*:*:*:* | 2.4.0 beta1 | Vulnerable | OpenVPN |
| cpe:2.3:a:openvpn:openvpn:2.4.0:beta2:*:*:*:*:*:* | 2.4.0 beta2 | Vulnerable | OpenVPN |
| cpe:2.3:a:openvpn:openvpn:2.4.0:rc1:*:*:*:*:*:* | 2.4.0 rc1 | Vulnerable | OpenVPN |
| cpe:2.3:a:openvpn:openvpn:2.4.0:rc2:*:*:*:*:*:* | 2.4.0 rc2 | Vulnerable | OpenVPN |
| cpe:2.3:a:openvpn:openvpn:2.4.1:*:*:*:*:*:*:* | 2.4.1 | Vulnerable | OpenVPN |
- cpe:2.3:a:openvpn:openvpn:*:*:*:*:*:*:*:* Versions up to 2.3.14 Vulnerable ·OpenVPN
- cpe:2.3:a:openvpn:openvpn:2.4.0:*:*:*:*:*:*:* Versions 2.4.0 Vulnerable ·OpenVPN
- cpe:2.3:a:openvpn:openvpn:2.4.0:alpha2:*:*:*:*:*:* Versions 2.4.0 alpha2 Vulnerable ·OpenVPN
- cpe:2.3:a:openvpn:openvpn:2.4.0:beta1:*:*:*:*:*:* Versions 2.4.0 beta1 Vulnerable ·OpenVPN
- cpe:2.3:a:openvpn:openvpn:2.4.0:beta2:*:*:*:*:*:* Versions 2.4.0 beta2 Vulnerable ·OpenVPN
- cpe:2.3:a:openvpn:openvpn:2.4.0:rc1:*:*:*:*:*:* Versions 2.4.0 rc1 Vulnerable ·OpenVPN
- cpe:2.3:a:openvpn:openvpn:2.4.0:rc2:*:*:*:*:*:* Versions 2.4.0 rc2 Vulnerable ·OpenVPN
- cpe:2.3:a:openvpn:openvpn:2.4.1:*:*:*:*:*:*:* Versions 2.4.1 Vulnerable ·OpenVPN
Remediation
- Fix · CNA openvpn (OpenVPN Technologies, Inc) Fixed in 2.3.15, 2.4.2
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-7479
- 2026-10-03 Alias added: GHSA-qhqf-49x5-89w6
References
More Openvpn vulnerabilities
- TI-2014-04453 Unquoted Windows search path vulnerability in the ptservice service prior to… CVSS 3.1MEDIUM 5.3
- TI-2022-00467 Authentication bypass in OpenVPN CVSS 3.1CRITICAL 9.8
- TI-2024-18509 Unrestricted file upload in OpenVPN 2 CVSS 3.1CRITICAL 9.8
- TI-2024-16468 The interactive service in OpenVPN 2.6.9 and earlier allows the OpenVPN service pipe to… CVSS 3.1HIGH 7.5
- TI-2023-25309 Use after free in OpenVPN 2 CVSS 3.1CRITICAL 9.8
- TI-2024-05196 OpenVPN before 2.6.11 does not santize PUSH_REPLY messages properly which an attacker… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2017-7479 · CVE Program
- CVE-2017-7479 · NVD
- FIRST EPSS
- GHSA-qhqf-49x5-89w6 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-7479 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences