Read the docs
TI-2017-05127 Aliases CVE-2017-7481GHSA-w578-j992-554x

Improper input validation in [UNKNOWN] ansible

Priority MEDIUM 50CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 9 fixed, 1 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.

Summary

Ansible before versions 2.3.1.0 and 2.4.0.0 fails to properly mark lookup-plugin results as unsafe. If an attacker could control the results of lookup() calls, they could inject Unicode strings to be parsed by the jinja2 templating system, resulting in code execution. By default, the jinja2 templating language is now marked as 'unsafe' and is not evaluated.

Why it matters now

EPSS 0.04743 91st percentileScored 2026-11-07
Fix Partial ansible (PyPI): 2.3.1.0, 2.1.6.0, 2.2.3.0Red Hat: 6 advisoriesRed Hat: 9 fixed, 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
[UNKNOWN]ansibleansible 2.3.1.0; ansible 2.4.0.0—No fix listedCNA
—ansible (PyPI)2.3.0.0 to before 2.3.1.02.3.1.0Patch availableGHSA-w578-j992-554x
—ansible (PyPI)before 2.1.6.02.1.6.0Patch availableGHSA-w578-j992-554x
—ansible (PyPI)2.2.0.0 to before 2.2.3.02.2.3.0Patch availableGHSA-w578-j992-554x
  • ansible Vendor[UNKNOWN] Affected ansible 2.3.1.0; ansible 2.4.0.0 Fixed in — No fix listed CNA
  • ansible (PyPI) Vendor— Affected 2.3.0.0 to before 2.3.1.0 Fixed in 2.3.1.0 Patch available GHSA-w578-j992-554x
  • ansible (PyPI) Vendor— Affected before 2.1.6.0 Fixed in 2.1.6.0 Patch available GHSA-w578-j992-554x
  • ansible (PyPI) Vendor— Affected 2.2.0.0 to before 2.2.3.0 Fixed in 2.2.3.0 Patch available GHSA-w578-j992-554x

CPE configurations NVD · 15

CPEVersionsRoleVendor
cpe:2.3:a:redhat:openshift_container_platform:3.3:*:*:*:*:*:*:*3.3VulnerableRed Hat
cpe:2.3:a:redhat:openshift_container_platform:3.4:*:*:*:*:*:*:*3.4VulnerableRed Hat
cpe:2.3:a:redhat:openshift_container_platform:3.5:*:*:*:*:*:*:*3.5VulnerableRed Hat
cpe:2.3:a:redhat:openstack:10:*:*:*:*:*:*:*10VulnerableRed Hat
cpe:2.3:a:redhat:openstack:11:*:*:*:*:*:*:*11VulnerableRed Hat
cpe:2.3:a:redhat:storage_console:2.0:*:*:*:*:*:*:*2.0VulnerableRed Hat
cpe:2.3:a:redhat:virtualization:4.1:*:*:*:*:*:*:*4.1VulnerableRed Hat
cpe:2.3:a:redhat:virtualization_manager:4.1:*:*:*:*:*:*:*4.1VulnerableRed Hat
cpe:2.3:a:redhat:gluster_storage:3.2:*:*:*:*:*:*:*3.2VulnerableRed Hat
cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:*7.0Running onRed Hat
  • cpe:2.3:a:redhat:openshift_container_platform:3.3:*:*:*:*:*:*:* Versions 3.3 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:openshift_container_platform:3.4:*:*:*:*:*:*:* Versions 3.4 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:openshift_container_platform:3.5:*:*:*:*:*:*:* Versions 3.5 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:openstack:10:*:*:*:*:*:*:* Versions 10 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:openstack:11:*:*:*:*:*:*:* Versions 11 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:storage_console:2.0:*:*:*:*:*:*:* Versions 2.0 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:virtualization:4.1:*:*:*:*:*:*:* Versions 4.1 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:virtualization_manager:4.1:*:*:*:*:*:*:* Versions 4.1 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:gluster_storage:3.2:*:*:*:*:*:*:* Versions 3.2 Vulnerable ·Red Hat
  • cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Running on ·Red Hat
Show 5 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:redhat:ansible_engine:*:*:*:*:*:*:*:*before 2.3.1.0; 2.3.2.0 to before 2.4.0.0VulnerableRed Hat
cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:*16.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*18.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:19.04:*:*:*:*:*:*:*19.04VulnerableCanonical
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
  • cpe:2.3:a:redhat:ansible_engine:*:*:*:*:*:*:*:* Versions before 2.3.1.0; 2.3.2.0 to before 2.4.0.0 Vulnerable ·Red Hat
  • cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:19.04:*:*:*:*:*:*:* Versions 19.04 Vulnerable ·Canonical
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-w578-j992-554x ansible (PyPI) Fixed in 2.3.1.0 Advisory →
  • Fix · GHSA-w578-j992-554x ansible (PyPI) Fixed in 2.1.6.0 Advisory →
  • Fix · GHSA-w578-j992-554x ansible (PyPI) Fixed in 2.2.3.0 Advisory →

Red Hat 6 advisories

  • RHSA-2017:2524 Released 2017-08-22 · Red Hat rating Moderate
    ansible security, bug fix, and enhancement update
    • Red Hat Virtualization Manager 4.1 ansible-2.3.1.0-3.el7, ansible-doc-2.3.1.0-3.el7
  • RHSA-2017:1599 Released 2017-06-28 · Red Hat rating Important
    ansible security update
    • Red Hat OpenStack Platform 10.0 ansible-2.2.3.0-1.el7
  • RHSA-2017:1499 Released 2017-06-19 · Red Hat rating Important
    ansible security update
    • Red Hat Storage Console Installer 2 ansible-2.2.3.0-1.el7
Show 3 more Red Hat advisories
  • RHSA-2017:1476 Released 2017-06-15 · Red Hat rating Important
    ansible security update
    • Red Hat OpenStack Platform 11.0 ansible-2.2.3.0-1.el7
  • RHSA-2017:1334 Released 2017-05-25 · Red Hat rating Important
    ansible security update
    • Red Hat Gluster Storage Server 3.2 on RHEL-7 ansible-2.2.3.0-1.el7
  • RHSA-2017:1244 Released 2017-05-17 · Red Hat rating Important
    ansible and openshift-ansible security and bug fix update
    • Red Hat OpenShift Container Platform 3.2 ansible-2.2.3.0-1.el7, atomic-openshift-utils-3.2.56-1.git.0.b844ab7.el7, openshift-ansible-3.2.56-1.git.0.b844ab7.el7 +5
    • Red Hat OpenShift Container Platform 3.3 ansible-2.2.3.0-1.el7, atomic-openshift-utils-3.3.82-1.git.0.af0c922.el7, openshift-ansible-3.3.82-1.git.0.af0c922.el7 +6
    • Red Hat OpenShift Container Platform 3.4 ansible-2.2.3.0-1.el7, atomic-openshift-utils-3.4.89-1.git.0.ac29ce8.el7, openshift-ansible-3.4.89-1.git.0.ac29ce8.el7 +6
    • Red Hat OpenShift Container Platform 3.5 ansible-2.2.3.0-1.el7, atomic-openshift-utils-3.5.71-1.git.0.128c2db.el7, openshift-ansible-3.5.71-1.git.0.128c2db.el7 +6

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Quickstart Cloud Installer 1AffectedNo fix yet
Red Hat Gluster Storage Server 3.2 on RHEL-7Fixed RHSA-2017:1334
Red Hat OpenShift Container Platform 3.2Fixed RHSA-2017:1244
Red Hat OpenShift Container Platform 3.3Fixed RHSA-2017:1244
Red Hat OpenShift Container Platform 3.4Fixed RHSA-2017:1244
Red Hat OpenShift Container Platform 3.5Fixed RHSA-2017:1244
Red Hat OpenStack Platform 10.0Fixed RHSA-2017:1599
Red Hat OpenStack Platform 11.0Fixed RHSA-2017:1476
Red Hat Storage Console Installer 2Fixed RHSA-2017:1499
Red Hat Virtualization Manager 4.1Fixed RHSA-2017:2524
Not affected: 1 product
  • Red Hat OpenStack Platform 12 (Pike)

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-7481
  2. 2026-10-03 Alias added: GHSA-w578-j992-554x

References

Sources