Reachable assertion in OpenVPN
Priority MEDIUM 40CWE-617Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-617.
Summary
OpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to remote denial-of-service when receiving malformed IPv6 packet.
Why it matters now
EPSS 0.04759 91st percentileScored 2026-11-07
Fix Fixed OpenVPN (OpenVPN Technologies, Inc): 2.4.3, 2.3.17
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenVPN | OpenVPN | before 2.4.3; before 2.3.17 | 2.4.3, 2.3.17 | Patch available | CNA |
- OpenVPN VendorOpenVPN Affected before 2.4.3; before 2.3.17 Fixed in 2.4.3, 2.3.17 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openvpn:openvpn:*:*:*:*:*:*:*:* | up to 2.3.16 | Vulnerable | OpenVPN |
| cpe:2.3:a:openvpn:openvpn:2.4.0:*:*:*:*:*:*:* | 2.4.0 | Vulnerable | OpenVPN |
| cpe:2.3:a:openvpn:openvpn:2.4.0:alpha2:*:*:*:*:*:* | 2.4.0 alpha2 | Vulnerable | OpenVPN |
| cpe:2.3:a:openvpn:openvpn:2.4.0:beta1:*:*:*:*:*:* | 2.4.0 beta1 | Vulnerable | OpenVPN |
| cpe:2.3:a:openvpn:openvpn:2.4.0:beta2:*:*:*:*:*:* | 2.4.0 beta2 | Vulnerable | OpenVPN |
| cpe:2.3:a:openvpn:openvpn:2.4.0:rc1:*:*:*:*:*:* | 2.4.0 rc1 | Vulnerable | OpenVPN |
| cpe:2.3:a:openvpn:openvpn:2.4.0:rc2:*:*:*:*:*:* | 2.4.0 rc2 | Vulnerable | OpenVPN |
| cpe:2.3:a:openvpn:openvpn:2.4.1:*:*:*:*:*:*:* | 2.4.1 | Vulnerable | OpenVPN |
| cpe:2.3:a:openvpn:openvpn:2.4.2:*:*:*:*:*:*:* | 2.4.2 | Vulnerable | OpenVPN |
- cpe:2.3:a:openvpn:openvpn:*:*:*:*:*:*:*:* Versions up to 2.3.16 Vulnerable ·OpenVPN
- cpe:2.3:a:openvpn:openvpn:2.4.0:*:*:*:*:*:*:* Versions 2.4.0 Vulnerable ·OpenVPN
- cpe:2.3:a:openvpn:openvpn:2.4.0:alpha2:*:*:*:*:*:* Versions 2.4.0 alpha2 Vulnerable ·OpenVPN
- cpe:2.3:a:openvpn:openvpn:2.4.0:beta1:*:*:*:*:*:* Versions 2.4.0 beta1 Vulnerable ·OpenVPN
- cpe:2.3:a:openvpn:openvpn:2.4.0:beta2:*:*:*:*:*:* Versions 2.4.0 beta2 Vulnerable ·OpenVPN
- cpe:2.3:a:openvpn:openvpn:2.4.0:rc1:*:*:*:*:*:* Versions 2.4.0 rc1 Vulnerable ·OpenVPN
- cpe:2.3:a:openvpn:openvpn:2.4.0:rc2:*:*:*:*:*:* Versions 2.4.0 rc2 Vulnerable ·OpenVPN
- cpe:2.3:a:openvpn:openvpn:2.4.1:*:*:*:*:*:*:* Versions 2.4.1 Vulnerable ·OpenVPN
- cpe:2.3:a:openvpn:openvpn:2.4.2:*:*:*:*:*:*:* Versions 2.4.2 Vulnerable ·OpenVPN
Remediation
- Fix · CNA OpenVPN (OpenVPN Technologies, Inc) Fixed in 2.4.3, 2.3.17
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-7508
- 2026-10-03 Alias added: GHSA-q55c-22v4-x379
References
More Openvpn vulnerabilities
- TI-2014-04453 Unquoted Windows search path vulnerability in the ptservice service prior to… CVSS 3.1MEDIUM 5.3
- TI-2022-00467 Authentication bypass in OpenVPN CVSS 3.1CRITICAL 9.8
- TI-2024-18509 Unrestricted file upload in OpenVPN 2 CVSS 3.1CRITICAL 9.8
- TI-2024-16468 The interactive service in OpenVPN 2.6.9 and earlier allows the OpenVPN service pipe to… CVSS 3.1HIGH 7.5
- TI-2023-25309 Use after free in OpenVPN 2 CVSS 3.1CRITICAL 9.8
- TI-2024-05196 OpenVPN before 2.6.11 does not santize PUSH_REPLY messages properly which an attacker… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2017-7508 · CVE Program
- CVE-2017-7508 · NVD
- FIRST EPSS
- GHSA-q55c-22v4-x379 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-7508 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences