rubygem-safemode, as used in Foreman, versions 1.3.2 and earlier are vulnerable to…
Priority MEDIUM 45CWE-184Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
rubygem-safemode, as used in Foreman, versions 1.3.2 and earlier are vulnerable to bypassing safe mode limitations via special Ruby syntax. This can lead to deletion of objects for which the user does not have delete permissions or possibly to privilege escalation.
Why it matters now
EPSS 0.01627 76th percentileScored 2026-11-07
Fix Partial safemode (RubyGems): 1.3.2Red Hat: 3 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Red Hat | rubygem-safemode | up to 1.3.2 | — | No fix listed | CNA |
| — | safemode (RubyGems) | before 1.3.2 | 1.3.2 | Patch available | GHSA-5vx5-9q73-wgp4 |
- rubygem-safemode VendorRed Hat Affected up to 1.3.2 Fixed in — No fix listed CNA
- safemode (RubyGems) Vendor— Affected before 1.3.2 Fixed in 1.3.2 Patch available GHSA-5vx5-9q73-wgp4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:safemode_project:safemode:*:*:*:*:*:ruby:*:* | up to 1.3.2 | Vulnerable | Safemode Project |
- cpe:2.3:a:safemode_project:safemode:*:*:*:*:*:ruby:*:* Versions up to 1.3.2 Vulnerable ·Safemode Project
Remediation
- Fix · GHSA-5vx5-9q73-wgp4 safemode (RubyGems) Fixed in 1.3.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ceph Storage 1.3 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux OpenStack Platform 6 (Juno) Installer | Affected | No fix planned: Will not fix |
| Red Hat Satellite 6 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2017-7540
- 2026-10-03 Alias added: GHSA-5vx5-9q73-wgp4
References
More Red Hat vulnerabilities
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-05363 Code injection in Elastic Kibana KEVCVSS 3.1CRITICAL 10.0
- TI-2019-03949 Out-of-bounds write in ESXi and Horizon DaaS KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2017-7540 · CVE Program
- CVE-2017-7540 · NVD
- FIRST EPSS
- GHSA-5vx5-9q73-wgp4 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-7540 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences