Origin validation error in Apache NiFi
Priority LOW 36CWE-346Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-346.
Summary
Apache NiFi before 0.7.4 and 1.x before 1.3.0 need to establish the response header telling browsers to only allow framing with the same origin.
Why it matters now
EPSS 0.01431 73rd percentileScored 2026-11-07
Fix Fixed org.apache.nifi:nifi (Maven): 0.7.4, 1.3.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache NiFi | 0.0.1 to 0.7.3; 1.0.0 to 1.2.0 | — | No fix listed | CNA |
| — | org.apache.nifi:nifi (Maven) | before 0.7.4 | 0.7.4 | Patch available | GHSA-jvx9-rj3w-jq99 |
| — | org.apache.nifi:nifi (Maven) | 1.0.0 to before 1.3.0 | 1.3.0 | Patch available | GHSA-jvx9-rj3w-jq99 |
- Apache NiFi VendorApache Affected 0.0.1 to 0.7.3; 1.0.0 to 1.2.0 Fixed in — No fix listed CNA
- org.apache.nifi:nifi (Maven) Vendor— Affected before 0.7.4 Fixed in 0.7.4 Patch available GHSA-jvx9-rj3w-jq99
- org.apache.nifi:nifi (Maven) Vendor— Affected 1.0.0 to before 1.3.0 Fixed in 1.3.0 Patch available GHSA-jvx9-rj3w-jq99
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:nifi:*:*:*:*:*:*:*:* | up to 0.7.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:1.0.0:*:*:*:*:*:*:* | 1.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:1.0.1:*:*:*:*:*:*:* | 1.0.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:1.1.0:*:*:*:*:*:*:* | 1.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:1.1.1:*:*:*:*:*:*:* | 1.1.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:1.1.2:*:*:*:*:*:*:* | 1.1.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:1.2.0:*:*:*:*:*:*:* | 1.2.0 | Vulnerable | Apache |
- cpe:2.3:a:apache:nifi:*:*:*:*:*:*:*:* Versions up to 0.7.3 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:1.0.0:*:*:*:*:*:*:* Versions 1.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:1.0.1:*:*:*:*:*:*:* Versions 1.0.1 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:1.1.0:*:*:*:*:*:*:* Versions 1.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:1.1.1:*:*:*:*:*:*:* Versions 1.1.1 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:1.1.2:*:*:*:*:*:*:* Versions 1.1.2 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:1.2.0:*:*:*:*:*:*:* Versions 1.2.0 Vulnerable ·Apache
Remediation
- Fix · GHSA-jvx9-rj3w-jq99 org.apache.nifi:nifi (Maven) Fixed in 0.7.4 Advisory →
- Fix · GHSA-jvx9-rj3w-jq99 org.apache.nifi:nifi (Maven) Fixed in 1.3.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-7667
- 2026-10-03 Alias added: GHSA-jvx9-rj3w-jq99
References
More Apache Nifi vulnerabilities
- TI-2023-17293 Apache NiFi: Potential Code Injection with Database Services using H2 CVSS 3.1HIGH 8.8
- TI-2020-16549 Uncontrolled resource consumption in Eclipse Jetty CVSS 3.1MEDIUM 5.3
- TI-2019-07411 Deserialization of untrusted data in Apache Commons Beanutils CVSS 3.1HIGH 7.3
- TI-2017-11471 Improper input validation in Apache NiFi CVSS 3.0CRITICAL 9.8
- TI-2018-01212 XML external entity injection in Apache NiFi CVSS 3.0CRITICAL 9.8
- TI-2021-03489 Deserialization of untrusted data in jackson-databind CVSS 3.1HIGH 8.1
Sources
- CVE-2017-7667 · CVE Program
- CVE-2017-7667 · NVD
- FIRST EPSS
- GHSA-jvx9-rj3w-jq99 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences