Read the docs
TI-2017-05314 Aliases CVE-2017-7678GHSA-r34r-f84j-5x4x

In Apache Spark before 2.2.0, it is possible for an attacker to take advantage of a…

Priority LOW 33CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

In Apache Spark before 2.2.0, it is possible for an attacker to take advantage of a user's trust in the server to trick them into visiting a link that points to a shared Spark cluster and submits data including MHTML to the Spark master, or history server. This data, which could contain a script, would then be reflected back to the user and could be evaluated and executed by MS Windows-based clients. It is not an attack on Spark itself, but on the user, who may then execute the script inadvertently when viewing elements of the Spark web UIs.

Why it matters now

EPSS 0.0338 88th percentileScored 2026-11-07
Fix Fixed org.apache.spark:spark-core_2.11 (Maven): 2.2.0org.apache.spark:spark-core_2.10 (Maven): 2.2.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.apache.spark:spark-core_2.11 (Maven)before 2.2.02.2.0Patch availableGHSA-r34r-f84j-5x4x
—org.apache.spark:spark-core_2.10 (Maven)before 2.2.02.2.0Patch availableGHSA-r34r-f84j-5x4x
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.apache.spark:spark-core_2.11 (Maven) Vendor— Affected before 2.2.0 Fixed in 2.2.0 Patch available GHSA-r34r-f84j-5x4x
  • org.apache.spark:spark-core_2.10 (Maven) Vendor— Affected before 2.2.0 Fixed in 2.2.0 Patch available GHSA-r34r-f84j-5x4x

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:spark:*:*:*:*:*:*:*:*up to 2.1.1VulnerableApache
  • cpe:2.3:a:apache:spark:*:*:*:*:*:*:*:* Versions up to 2.1.1 Vulnerable ·Apache

Remediation

  • Fix · GHSA-r34r-f84j-5x4x org.apache.spark:spark-core_2.11 (Maven) Fixed in 2.2.0 Advisory →
  • Fix · GHSA-r34r-f84j-5x4x org.apache.spark:spark-core_2.10 (Maven) Fixed in 2.2.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-7678
  2. 2026-10-03 Alias added: GHSA-r34r-f84j-5x4x

References

  • TI-2022-14901 Apache Spark shell command injection vulnerability via Spark UI KEVCVSS 3.1HIGH 8.8
  • TI-2023-15314 Apache Spark: Shell command injection via Spark UI CVSS 3.1HIGH 8.8
  • TI-2020-07589 Missing authentication in Apache Spark CVSS 3.1CRITICAL 9.8
  • TI-2020-16549 Uncontrolled resource consumption in Eclipse Jetty CVSS 3.1MEDIUM 5.3
  • TI-2019-14677 HttpObjectDecoder.java in Netty before 4.1.44 allows a Content-Length header to be… CVSS 3.1CRITICAL 9.1
  • TI-2018-08427 Improper authentication in Apache Spark CVSS 3.1MEDIUM 4.2
See all 22 →

Sources