Read the docs
TI-2017-06515 Aliases CVE-2017-9050GHSA-8c56-cpmw-89x7

libxml2 20904-GITv2.9.4-16-g0741801 is vulnerable to a heap-based buffer over-read in the…

Priority MEDIUM 46CWE-122Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 1 fixed, 6 without a fix

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-122 and the CVSS impact.

Summary

libxml2 20904-GITv2.9.4-16-g0741801 is vulnerable to a heap-based buffer over-read in the xmlDictAddString function in dict.c. This vulnerability causes programs that use libxml2, such as PHP, to crash. This vulnerability exists because of an incomplete fix for CVE-2016-1839.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.04626 91st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial nokogiri (RubyGems): 1.8.1Red Hat: 1 advisoryRed Hat: 1 fixed, 6 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—nokogiri (RubyGems)before 1.8.11.8.1Patch availableGHSA-8c56-cpmw-89x7
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • nokogiri (RubyGems) Vendor— Affected before 1.8.1 Fixed in 1.8.1 Patch available GHSA-8c56-cpmw-89x7

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:xmlsoft:libxml2:2.9.4:*:*:*:*:*:*:*2.9.4Vulnerablexmlsoft
  • cpe:2.3:a:xmlsoft:libxml2:2.9.4:*:*:*:*:*:*:* Versions 2.9.4 Vulnerable ·xmlsoft

Remediation

  • Fix · GHSA-8c56-cpmw-89x7 nokogiri (RubyGems) Fixed in 1.8.1 Advisory →

Red Hat 1 advisory

  • RHSA-2018:2486 Released 2018-08-16 · Red Hat rating Important
    Red Hat JBoss Core Services Apache HTTP Server 2.4.29 security update
    • Red Hat JBoss Core Services

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 5AffectedNo fix planned: Will not fix
Red Hat Enterprise Linux 6AffectedNo fix planned: Will not fix
Red Hat Enterprise Linux 7AffectedNo fix planned: Will not fix
Red Hat Enterprise Linux 8AffectedNo fix yet
Red Hat JBoss Core ServicesAffectedNo fix yet
Red Hat JBoss Enterprise Web Server 3AffectedNo fix planned: Will not fix
Red Hat JBoss Core ServicesFixed RHSA-2018:2486
Not affected: 1 product
  • Red Hat Enterprise Linux 8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-9050
  2. 2026-10-03 Alias added: GHSA-8c56-cpmw-89x7

References

  • TI-2020-06117 xmlStringLenDecodeEntities in parser.c in libxml2 2.9.10 has an infinite loop in a certain end-of-file situation. CVSS 3.1HIGH 7.5
  • TI-2025-05441 Libxml2: integer overflow in xmlbuildqname() leads to stack buffer overflow in libxml2 CVSS 3.1HIGH 7.5
  • TI-2024-22792 An issue was discovered in xmllint (from libxml2) before 2.11.8 and 2.12.x before 2.12.7. CVSS 3.1HIGH 7.5
  • TI-2017-06514 libxml2 20904-GITv2.9.4-16-g0741801 is vulnerable to a heap-based buffer over-read in the… CVSS 3.1HIGH 7.5
  • TI-2022-19140 An issue was discovered in libxml2 before 2.10.3. CVSS 3.1HIGH 7.5
  • TI-2025-23491 Out-of-bounds read in xmlsoft libxml2 CVSS 3.1HIGH 7.5
See all 114 →

Sources