In MODX Revolution before 2.5.7, when PHP 5.3.3 is used, an attacker is able to include…
Priority LOW 32CWE-22Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
In MODX Revolution before 2.5.7, when PHP 5.3.3 is used, an attacker is able to include and execute arbitrary files on the web server due to insufficient validation of the action parameter to setup/index.php, aka directory traversal.
Why it matters now
EPSS 0.0082 57th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed modx/revolution (Packagist): 2.5.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | modx/revolution (Packagist) | before 2.5.7 | 2.5.7 | Patch available | GHSA-cgrv-6h2h-6f7v |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- modx/revolution (Packagist) Vendor— Affected before 2.5.7 Fixed in 2.5.7 Patch available GHSA-cgrv-6h2h-6f7v
Remediation
- Fix · GHSA-cgrv-6h2h-6f7v modx/revolution (Packagist) Fixed in 2.5.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-9067
- 2026-10-03 Alias added: GHSA-cgrv-6h2h-6f7v
References
Advisory 3
Sources
- CVE-2017-9067 · CVE Program
- CVE-2017-9067 · NVD
- FIRST EPSS
- GHSA-cgrv-6h2h-6f7v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences