Improper input validation in Apache Commons Email
Priority MEDIUM 42CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
When a call-site passes a subject for an email that contains line-breaks in Apache Commons Email 1.0 through 1.4, the caller can add arbitrary SMTP headers.
Why it matters now
EPSS 0.06036 93rd percentileScored 2026-11-07
Fix Fixed org.apache.commons:commons-email (Maven): 1.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Commons Email | 1.0 to 1.4 | — | No fix listed | CNA |
| — | org.apache.commons:commons-email (Maven) | 1.0 to before 1.5 | 1.5 | Patch available | GHSA-p7vm-phxx-g722 |
- Apache Commons Email VendorApache Affected 1.0 to 1.4 Fixed in — No fix listed CNA
- org.apache.commons:commons-email (Maven) Vendor— Affected 1.0 to before 1.5 Fixed in 1.5 Patch available GHSA-p7vm-phxx-g722
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:commons_email:1.0:*:*:*:*:*:*:* | 1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:commons_email:1.1:*:*:*:*:*:*:* | 1.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:commons_email:1.2:*:*:*:*:*:*:* | 1.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:commons_email:1.3:*:*:*:*:*:*:* | 1.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:commons_email:1.3.1:*:*:*:*:*:*:* | 1.3.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:commons_email:1.3.2:*:*:*:*:*:*:* | 1.3.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:commons_email:1.3.3:*:*:*:*:*:*:* | 1.3.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:commons_email:1.4:*:*:*:*:*:*:* | 1.4 | Vulnerable | Apache |
- cpe:2.3:a:apache:commons_email:1.0:*:*:*:*:*:*:* Versions 1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:commons_email:1.1:*:*:*:*:*:*:* Versions 1.1 Vulnerable ·Apache
- cpe:2.3:a:apache:commons_email:1.2:*:*:*:*:*:*:* Versions 1.2 Vulnerable ·Apache
- cpe:2.3:a:apache:commons_email:1.3:*:*:*:*:*:*:* Versions 1.3 Vulnerable ·Apache
- cpe:2.3:a:apache:commons_email:1.3.1:*:*:*:*:*:*:* Versions 1.3.1 Vulnerable ·Apache
- cpe:2.3:a:apache:commons_email:1.3.2:*:*:*:*:*:*:* Versions 1.3.2 Vulnerable ·Apache
- cpe:2.3:a:apache:commons_email:1.3.3:*:*:*:*:*:*:* Versions 1.3.3 Vulnerable ·Apache
- cpe:2.3:a:apache:commons_email:1.4:*:*:*:*:*:*:* Versions 1.4 Vulnerable ·Apache
Remediation
- Fix · GHSA-p7vm-phxx-g722 org.apache.commons:commons-email (Maven) Fixed in 1.5 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-9801
- 2026-10-03 Alias added: GHSA-p7vm-phxx-g722
References
More Apache Commons Email vulnerabilities
- TI-2018-01198 Improper input validation in Apache Commons Email CVSS 3.0HIGH 7.5
Sources
- CVE-2017-9801 · CVE Program
- CVE-2017-9801 · NVD
- FIRST EPSS
- GHSA-p7vm-phxx-g722 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-9801 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences