Qt for Android prior to 5.9.0 allows remote attackers to execute arbitrary OS commands via unspecified vectors.
Priority MEDIUM 46CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-78.
Summary
Qt for Android prior to 5.9.0 allows remote attackers to execute arbitrary OS commands via unspecified vectors.
Why it matters now
EPSS 0.01958 80th percentileScored 2026-11-07
Fix Fixed Qt for Android (The Qt Company): 5.9.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA Qt for Android (The Qt Company) Fixed in 5.9.0
Timeline
- 2026-10-02 Threatist record created from CVE-2017-10904
- 2026-10-03 Alias added: GHSA-872g-v8g9-374r
References
More Qt vulnerabilities
- TI-2024-23902 QAbstractOAuth in Qt Network Authorization in Qt before 5.15.17, 6.x before 6.2.13, 6.3.x… CVSS 3.1CRITICAL 9.8
- TI-2022-21359 Heap-based buffer overflow in Qt CVSS 3.1HIGH 8.8
- TI-2022-19524 Integer overflow in Qt CVSS 3.1HIGH 8.8
- TI-2023-18997 In Qt before 5.15.15, 6.x before 6.2.9, and 6.3.x through 6.5.x before 6.5.2, there can… CVSS 3.1HIGH 7.5
- TI-2021-09305 Integer Overflow vulnerability in qsvghandler.cpp in Qt qtsvg versions 5.15.1, 6.0.0… CVSS 3.1MEDIUM 5.5
- TI-2023-28356 An issue was discovered in the HTTP2 implementation in Qt before 5.15.17, 6.x before… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2017-10904 · CVE Program
- CVE-2017-10904 · NVD
- FIRST EPSS
- GHSA-872g-v8g9-374r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences