Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may…
Priority MEDIUM 49Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 fixed, 5 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may allow an attacker to change the terminal UI or execute arbitrary commands on the device via unspecified vectors.
Why it matters now
EPSS 0.04581 91st percentileScored 2026-11-07
Fix Partial fluentd (RubyGems): 0.12.41Red Hat: 1 advisoryRed Hat: 1 fixed, 5 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cloud Native Computing Foundation (CNCF) | Fluentd | 0.12.29 through 0.12.40 | — | No fix listed | CNA |
| — | fluentd (RubyGems) | 0.12.29 to before 0.12.41 | 0.12.41 | Patch available | GHSA-5jrp-w8fr-mrww |
- Fluentd VendorCloud Native Computing Foundation (CNCF) Affected 0.12.29 through 0.12.40 Fixed in — No fix listed CNA
- fluentd (RubyGems) Vendor— Affected 0.12.29 to before 0.12.41 Fixed in 0.12.41 Patch available GHSA-5jrp-w8fr-mrww
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fluentd:fluentd:0.12.29:*:*:*:*:*:*:* | 0.12.29 | Vulnerable | fluent |
| cpe:2.3:a:fluentd:fluentd:0.12.30:*:*:*:*:*:*:* | 0.12.30 | Vulnerable | fluent |
| cpe:2.3:a:fluentd:fluentd:0.12.31:*:*:*:*:*:*:* | 0.12.31 | Vulnerable | fluent |
| cpe:2.3:a:fluentd:fluentd:0.12.32:*:*:*:*:*:*:* | 0.12.32 | Vulnerable | fluent |
| cpe:2.3:a:fluentd:fluentd:0.12.33:*:*:*:*:*:*:* | 0.12.33 | Vulnerable | fluent |
| cpe:2.3:a:fluentd:fluentd:0.12.34:*:*:*:*:*:*:* | 0.12.34 | Vulnerable | fluent |
| cpe:2.3:a:fluentd:fluentd:0.12.35:*:*:*:*:*:*:* | 0.12.35 | Vulnerable | fluent |
| cpe:2.3:a:fluentd:fluentd:0.12.36:*:*:*:*:*:*:* | 0.12.36 | Vulnerable | fluent |
| cpe:2.3:a:fluentd:fluentd:0.12.37:*:*:*:*:*:*:* | 0.12.37 | Vulnerable | fluent |
| cpe:2.3:a:fluentd:fluentd:0.12.38:*:*:*:*:*:*:* | 0.12.38 | Vulnerable | fluent |
- cpe:2.3:a:fluentd:fluentd:0.12.29:*:*:*:*:*:*:* Versions 0.12.29 Vulnerable ·fluent
- cpe:2.3:a:fluentd:fluentd:0.12.30:*:*:*:*:*:*:* Versions 0.12.30 Vulnerable ·fluent
- cpe:2.3:a:fluentd:fluentd:0.12.31:*:*:*:*:*:*:* Versions 0.12.31 Vulnerable ·fluent
- cpe:2.3:a:fluentd:fluentd:0.12.32:*:*:*:*:*:*:* Versions 0.12.32 Vulnerable ·fluent
- cpe:2.3:a:fluentd:fluentd:0.12.33:*:*:*:*:*:*:* Versions 0.12.33 Vulnerable ·fluent
- cpe:2.3:a:fluentd:fluentd:0.12.34:*:*:*:*:*:*:* Versions 0.12.34 Vulnerable ·fluent
- cpe:2.3:a:fluentd:fluentd:0.12.35:*:*:*:*:*:*:* Versions 0.12.35 Vulnerable ·fluent
- cpe:2.3:a:fluentd:fluentd:0.12.36:*:*:*:*:*:*:* Versions 0.12.36 Vulnerable ·fluent
- cpe:2.3:a:fluentd:fluentd:0.12.37:*:*:*:*:*:*:* Versions 0.12.37 Vulnerable ·fluent
- cpe:2.3:a:fluentd:fluentd:0.12.38:*:*:*:*:*:*:* Versions 0.12.38 Vulnerable ·fluent
Remediation
- Fix · GHSA-5jrp-w8fr-mrww fluentd (RubyGems) Fixed in 0.12.41 Advisory →
Red Hat 1 advisory
- RHSA-2018:2225 Released 2018-07-19 · Red Hat rating Moderatefluentd security update
- Red Hat OpenStack Platform 13.0 Operational Tools for RHEL 7 fluentd-0.12.41-1.el7
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Enterprise 3 | Affected | No fix yet |
| Red Hat OpenStack Platform 10 (Newton) Operational Tools | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 11 (Ocata) Operational Tools | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 12 (Pike) Operational Tools | Affected | No fix planned: Will not fix |
| Red Hat Virtualization 4 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 13.0 Operational Tools for RHEL 7 | Fixed | RHSA-2018:2225 |
Timeline
- 2026-10-02 Threatist record created from CVE-2017-10906
- 2026-10-03 Alias added: GHSA-5jrp-w8fr-mrww
References
Advisory 4
Sources
- CVE-2017-10906 · CVE Program
- CVE-2017-10906 · NVD
- FIRST EPSS
- GHSA-5jrp-w8fr-mrww · GitHub Advisory Database · CC BY 4.0
- CVE-2017-10906 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences