The XML-RPC server in supervisor before 3.0.1, 3.1.x before 3.1.4, 3.2.x before 3.2.4…
Priority HIGH 80CWE-276Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 fixed, 2 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
The XML-RPC server in supervisor before 3.0.1, 3.1.x before 3.1.4, 3.2.x before 3.2.4, and 3.3.x before 3.3.3 allows remote authenticated users to execute arbitrary commands via a crafted XML-RPC request, related to nested supervisord namespace lookups.
Why it matters now
EPSS 0.87549 99th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Partial supervisor (PyPI): 3.0.1, 3.1.4, 3.2.4 +1Red Hat: 1 advisoryRed Hat: 1 fixed, 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | supervisor (PyPI) | before 3.0.1 | 3.0.1 | Patch available | GHSA-x7c8-4x3h-874w |
| — | supervisor (PyPI) | 3.1.0 to before 3.1.4 | 3.1.4 | Patch available | GHSA-x7c8-4x3h-874w |
| — | supervisor (PyPI) | 3.2.0 to before 3.2.4 | 3.2.4 | Patch available | GHSA-x7c8-4x3h-874w |
| — | supervisor (PyPI) | 3.3.0 to before 3.3.3 | 3.3.3 | Patch available | GHSA-x7c8-4x3h-874w |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- supervisor (PyPI) Vendor— Affected before 3.0.1 Fixed in 3.0.1 Patch available GHSA-x7c8-4x3h-874w
- supervisor (PyPI) Vendor— Affected 3.1.0 to before 3.1.4 Fixed in 3.1.4 Patch available GHSA-x7c8-4x3h-874w
- supervisor (PyPI) Vendor— Affected 3.2.0 to before 3.2.4 Fixed in 3.2.4 Patch available GHSA-x7c8-4x3h-874w
- supervisor (PyPI) Vendor— Affected 3.3.0 to before 3.3.3 Fixed in 3.3.3 Patch available GHSA-x7c8-4x3h-874w
CPE configurations NVD · 18
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:supervisord:supervisor:*:*:*:*:*:*:*:* | up to 3.0 | Vulnerable | Supervisord |
| cpe:2.3:a:supervisord:supervisor:3.1.0:*:*:*:*:*:*:* | 3.1.0 | Vulnerable | Supervisord |
| cpe:2.3:a:supervisord:supervisor:3.1.1:*:*:*:*:*:*:* | 3.1.1 | Vulnerable | Supervisord |
| cpe:2.3:a:supervisord:supervisor:3.1.2:*:*:*:*:*:*:* | 3.1.2 | Vulnerable | Supervisord |
| cpe:2.3:a:supervisord:supervisor:3.1.3:*:*:*:*:*:*:* | 3.1.3 | Vulnerable | Supervisord |
| cpe:2.3:a:supervisord:supervisor:3.2.0:*:*:*:*:*:*:* | 3.2.0 | Vulnerable | Supervisord |
| cpe:2.3:a:supervisord:supervisor:3.2.1:*:*:*:*:*:*:* | 3.2.1 | Vulnerable | Supervisord |
| cpe:2.3:a:supervisord:supervisor:3.2.2:*:*:*:*:*:*:* | 3.2.2 | Vulnerable | Supervisord |
| cpe:2.3:a:supervisord:supervisor:3.2.3:*:*:*:*:*:*:* | 3.2.3 | Vulnerable | Supervisord |
| cpe:2.3:a:supervisord:supervisor:3.3.0:*:*:*:*:*:*:* | 3.3.0 | Vulnerable | Supervisord |
- cpe:2.3:a:supervisord:supervisor:*:*:*:*:*:*:*:* Versions up to 3.0 Vulnerable ·Supervisord
- cpe:2.3:a:supervisord:supervisor:3.1.0:*:*:*:*:*:*:* Versions 3.1.0 Vulnerable ·Supervisord
- cpe:2.3:a:supervisord:supervisor:3.1.1:*:*:*:*:*:*:* Versions 3.1.1 Vulnerable ·Supervisord
- cpe:2.3:a:supervisord:supervisor:3.1.2:*:*:*:*:*:*:* Versions 3.1.2 Vulnerable ·Supervisord
- cpe:2.3:a:supervisord:supervisor:3.1.3:*:*:*:*:*:*:* Versions 3.1.3 Vulnerable ·Supervisord
- cpe:2.3:a:supervisord:supervisor:3.2.0:*:*:*:*:*:*:* Versions 3.2.0 Vulnerable ·Supervisord
- cpe:2.3:a:supervisord:supervisor:3.2.1:*:*:*:*:*:*:* Versions 3.2.1 Vulnerable ·Supervisord
- cpe:2.3:a:supervisord:supervisor:3.2.2:*:*:*:*:*:*:* Versions 3.2.2 Vulnerable ·Supervisord
- cpe:2.3:a:supervisord:supervisor:3.2.3:*:*:*:*:*:*:* Versions 3.2.3 Vulnerable ·Supervisord
- cpe:2.3:a:supervisord:supervisor:3.3.0:*:*:*:*:*:*:* Versions 3.3.0 Vulnerable ·Supervisord
Show 8 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:supervisord:supervisor:3.3.1:*:*:*:*:*:*:* | 3.3.1 | Vulnerable | Supervisord |
| cpe:2.3:a:supervisord:supervisor:3.3.2:*:*:*:*:*:*:* | 3.3.2 | Vulnerable | Supervisord |
| cpe:2.3:o:fedoraproject:fedora:24:*:*:*:*:*:*:* | 24 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:25:*:*:*:*:*:*:* | 25 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:26:*:*:*:*:*:*:* | 26 | Vulnerable | Fedoraproject |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:a:redhat:cloudforms:4.5:*:*:*:*:*:*:* | 4.5 | Vulnerable | Red Hat |
- cpe:2.3:a:supervisord:supervisor:3.3.1:*:*:*:*:*:*:* Versions 3.3.1 Vulnerable ·Supervisord
- cpe:2.3:a:supervisord:supervisor:3.3.2:*:*:*:*:*:*:* Versions 3.3.2 Vulnerable ·Supervisord
- cpe:2.3:o:fedoraproject:fedora:24:*:*:*:*:*:*:* Versions 24 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:25:*:*:*:*:*:*:* Versions 25 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:26:*:*:*:*:*:*:* Versions 26 Vulnerable ·Fedoraproject
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:a:redhat:cloudforms:4.5:*:*:*:*:*:*:* Versions 4.5 Vulnerable ·Red Hat
Remediation
- Fix · GHSA-x7c8-4x3h-874w supervisor (PyPI) Fixed in 3.0.1 Advisory →
- Fix · GHSA-x7c8-4x3h-874w supervisor (PyPI) Fixed in 3.1.4 Advisory →
- Fix · GHSA-x7c8-4x3h-874w supervisor (PyPI) Fixed in 3.2.4 Advisory →
- Fix · GHSA-x7c8-4x3h-874w supervisor (PyPI) Fixed in 3.3.3 Advisory →
Red Hat 1 advisory
- RHSA-2017:3005 Released 2017-10-24 · Red Hat rating ImportantRed Hat CloudForms security, bug fix, and enhancement update
- CloudForms Management Engine 5.8 ansible-tower-server-3.1.5-1.el7at, ansible-tower-setup-3.1.5-1.el7at, cfme-5.8.2.3-1.el7cf +6
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ceph Storage 1.3 | Affected | No fix planned: Will not fix |
| Red Hat Ceph Storage 2 | Affected | No fix planned: Will not fix |
| CloudForms Management Engine 5.8 | Fixed | RHSA-2017:3005 |
Not affected: 1 product
- Red Hat Mobile Application Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2017-11610
- 2026-10-03 Alias added: GHSA-x7c8-4x3h-874w
References
Exploit 1
Advisory 13
- RHSA-2017:3005
- https://github.com/Supervisor/supervisor/blob/3.3.3/CHANGES.txt
- https://github.com/Supervisor/supervisor/blob/3.0.1/CHANGES.txt
- https://github.com/Supervisor/supervisor/blob/3.2.4/CHANGES.txt
- FEDORA-2017-307eab89e1
- FEDORA-2017-85eb9f7a36
- https://github.com/Supervisor/supervisor/blob/3.1.4/CHANGES.txt
- FEDORA-2017-713430fb15
- DSA-3942
- https://github.com/Supervisor/supervisor/issues/964
- GLSA-201709-06
- https://nvd.nist.gov/vuln/detail/CVE-2017-11610
- https://github.com/advisories/GHSA-x7c8-4x3h-874w
Other 6
- https://github.com/Supervisor/supervisor
- https://github.com/pypa/advisory-database/tree/main/vulns/supervisor/PYSEC-2017-41.yaml
- https://lists.fedoraproject.org/archives/list/[email protected]/message/4GMSCGMM477N64Z3BM34RWYBGSLK466B
- https://lists.fedoraproject.org/archives/list/[email protected]/message/DTPDZV4ZRICDYAYZVUHSYZAYDLRMG2IM
- https://lists.fedoraproject.org/archives/list/[email protected]/message/JXGWOJNSWWK2TTWQJZJUP66FLFIWDMBQ
- https://www.exploit-db.com/exploits/42779
Sources
- CVE-2017-11610 · CVE Program
- CVE-2017-11610 · NVD
- FIRST EPSS
- GHSA-x7c8-4x3h-874w · GitHub Advisory Database · CC BY 4.0
- CVE-2017-11610 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences