Read the docs
TI-2017-08857 Aliases CVE-2017-12061GHSA-98xr-mmq5-vc5h

An XSS issue was discovered in admin/install.php in MantisBT before 1.3.12 and 2.x before…

Priority LOW 33CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

An XSS issue was discovered in admin/install.php in MantisBT before 1.3.12 and 2.x before 2.5.2. Some variables under user control in the MantisBT installation script are not properly sanitized before being output, allowing remote attackers to inject arbitrary JavaScript code, as demonstrated by the $f_database, $f_db_username, and $f_admin_username variables. This is mitigated by the fact that the admin/ folder should be deleted after installation, and also prevented by CSP.

Why it matters now

EPSS 0.02937 87th percentileScored 2026-11-07
Fix Fixed mantisbt/mantisbt (Packagist): 1.3.12, 2.5.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—mantisbt/mantisbt (Packagist)before 1.3.121.3.12Patch availableGHSA-98xr-mmq5-vc5h
—mantisbt/mantisbt (Packagist)2.0.0 to before 2.5.22.5.2Patch availableGHSA-98xr-mmq5-vc5h
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • mantisbt/mantisbt (Packagist) Vendor— Affected before 1.3.12 Fixed in 1.3.12 Patch available GHSA-98xr-mmq5-vc5h
  • mantisbt/mantisbt (Packagist) Vendor— Affected 2.0.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-98xr-mmq5-vc5h

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:mantisbt:mantisbt:*:*:*:*:*:*:*:*1.3.0 to before 1.3.12; 2.0.0 to before 2.5.2Vulnerablemantisbt
  • cpe:2.3:a:mantisbt:mantisbt:*:*:*:*:*:*:*:* Versions 1.3.0 to before 1.3.12; 2.0.0 to before 2.5.2 Vulnerable ·mantisbt

Remediation

  • Fix · GHSA-98xr-mmq5-vc5h mantisbt/mantisbt (Packagist) Fixed in 1.3.12 Advisory →
  • Fix · GHSA-98xr-mmq5-vc5h mantisbt/mantisbt (Packagist) Fixed in 2.5.2 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-12061
  2. 2026-10-03 Alias added: GHSA-98xr-mmq5-vc5h

References

  • TI-2017-05251 MantisBT through 2.3.0 allows arbitrary password reset and unauthenticated admin access… CVSS 3.1HIGH 8.8
  • TI-2014-05966 The XmlImportExport plugin in MantisBT 1.2.17 and earlier allows remote attackers to… CVSS 2.0HIGH 7.5
  • TI-2025-38760 MantisBT unauthorized disclosure of private project column configuration CVSS 4.0MEDIUM 5.3
  • TI-2017-04981 A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page… CVSS 3.0MEDIUM 4.8
  • TI-2019-11797 MantisBT before 1.3.20 and 2.22.1 allows Post Authentication Command Injection, leading to Remote Code Execution. CVSS 3.1HIGH 7.2
  • TI-2014-07063 The XML Import/Export plugin in MantisBT 1.2.x does not restrict access, which allows… CVSS 2.0MEDIUM 6.4
See all 121 →

Sources