An XSS issue was discovered in manage_user_page.php in MantisBT 2.x before 2.5.2.
Priority LOW 34CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
An XSS issue was discovered in manage_user_page.php in MantisBT 2.x before 2.5.2. The 'filter' field is not sanitized before being rendered in the Manage User page, allowing remote attackers to execute arbitrary JavaScript code if CSP is disabled.
Why it matters now
EPSS 0.03904 90th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed mantisbt/mantisbt (Packagist): 2.5.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mantisbt/mantisbt (Packagist) | 2.0.0 to before 2.5.2 | 2.5.2 | Patch available | GHSA-w93w-rx52-24qh |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mantisbt/mantisbt (Packagist) Vendor— Affected 2.0.0 to before 2.5.2 Fixed in 2.5.2 Patch available GHSA-w93w-rx52-24qh
CPE configurations NVD · 18
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mantisbt:mantisbt:2.1.0:*:*:*:*:*:*:* | 2.1.0 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.1.1:*:*:*:*:*:*:* | 2.1.1 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.1.2:*:*:*:*:*:*:* | 2.1.2 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.1.3:*:*:*:*:*:*:* | 2.1.3 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.2.0:*:*:*:*:*:*:* | 2.2.0 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.2.1:*:*:*:*:*:*:* | 2.2.1 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.2.2:*:*:*:*:*:*:* | 2.2.2 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.2.3:*:*:*:*:*:*:* | 2.2.3 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.2.4:*:*:*:*:*:*:* | 2.2.4 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.3.0:*:*:*:*:*:*:* | 2.3.0 | Vulnerable | mantisbt |
- cpe:2.3:a:mantisbt:mantisbt:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.1.2:*:*:*:*:*:*:* Versions 2.1.2 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.1.3:*:*:*:*:*:*:* Versions 2.1.3 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.2.1:*:*:*:*:*:*:* Versions 2.2.1 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.2.2:*:*:*:*:*:*:* Versions 2.2.2 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.2.3:*:*:*:*:*:*:* Versions 2.2.3 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.2.4:*:*:*:*:*:*:* Versions 2.2.4 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.3.0:*:*:*:*:*:*:* Versions 2.3.0 Vulnerable ·mantisbt
Show 8 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mantisbt:mantisbt:2.3.1:*:*:*:*:*:*:* | 2.3.1 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.3.2:*:*:*:*:*:*:* | 2.3.2 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.3.3:*:*:*:*:*:*:* | 2.3.3 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.4.0:*:*:*:*:*:*:* | 2.4.0 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.4.1:*:*:*:*:*:*:* | 2.4.1 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.4.2:*:*:*:*:*:*:* | 2.4.2 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.5.0:*:*:*:*:*:*:* | 2.5.0 | Vulnerable | mantisbt |
| cpe:2.3:a:mantisbt:mantisbt:2.5.1:*:*:*:*:*:*:* | 2.5.1 | Vulnerable | mantisbt |
- cpe:2.3:a:mantisbt:mantisbt:2.3.1:*:*:*:*:*:*:* Versions 2.3.1 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.3.2:*:*:*:*:*:*:* Versions 2.3.2 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.3.3:*:*:*:*:*:*:* Versions 2.3.3 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.4.0:*:*:*:*:*:*:* Versions 2.4.0 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.4.1:*:*:*:*:*:*:* Versions 2.4.1 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.4.2:*:*:*:*:*:*:* Versions 2.4.2 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·mantisbt
- cpe:2.3:a:mantisbt:mantisbt:2.5.1:*:*:*:*:*:*:* Versions 2.5.1 Vulnerable ·mantisbt
Remediation
- Fix · GHSA-w93w-rx52-24qh mantisbt/mantisbt (Packagist) Fixed in 2.5.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-12062
- 2026-10-03 Alias added: GHSA-w93w-rx52-24qh
- 2026-10-08 EPSS moved to the 90th–95th percentile
References
Advisory 3
More Mantisbt vulnerabilities
- TI-2017-05251 MantisBT through 2.3.0 allows arbitrary password reset and unauthenticated admin access… CVSS 3.1HIGH 8.8
- TI-2014-05966 The XmlImportExport plugin in MantisBT 1.2.17 and earlier allows remote attackers to… CVSS 2.0HIGH 7.5
- TI-2025-38760 MantisBT unauthorized disclosure of private project column configuration CVSS 4.0MEDIUM 5.3
- TI-2017-04981 A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page… CVSS 3.0MEDIUM 4.8
- TI-2019-11797 MantisBT before 1.3.20 and 2.22.1 allows Post Authentication Command Injection, leading to Remote Code Execution. CVSS 3.1HIGH 7.2
- TI-2014-07063 The XML Import/Export plugin in MantisBT 1.2.x does not restrict access, which allows… CVSS 2.0MEDIUM 6.4
Sources
- CVE-2017-12062 · CVE Program
- CVE-2017-12062 · NVD
- FIRST EPSS
- GHSA-w93w-rx52-24qh · GitHub Advisory Database · CC BY 4.0
- CVE-2017-12062 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences