Read the docs
TI-2017-09327 Aliases CVE-2017-12601GHSA-w96g-3p64-63wr

OpenCV (Open Source Computer Vision Library) through 3.3 has a buffer overflow in the…

Priority MEDIUM 42CWE-120Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 2 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-120 and the CVSS impact.

Summary

OpenCV (Open Source Computer Vision Library) through 3.3 has a buffer overflow in the cv::BmpDecoder::readData function in modules/imgcodecs/src/grfmt_bmp.cpp when reading an image file by using cv::imread, as demonstrated by the 4-buf-overflow-readData-memcpy test case.

Why it matters now

EPSS 0.02088 81st percentileScored 2026-11-07
Fix Partial opencv-python (PyPI): 3.3.1.11opencv-contrib-python (PyPI): 3.3.1.11Red Hat: 2 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—opencv-python (PyPI)before 3.3.1.113.3.1.11Patch availableGHSA-w96g-3p64-63wr
—opencv-contrib-python (PyPI)before 3.3.1.113.3.1.11Patch availableGHSA-w96g-3p64-63wr
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • opencv-python (PyPI) Vendor— Affected before 3.3.1.11 Fixed in 3.3.1.11 Patch available GHSA-w96g-3p64-63wr
  • opencv-contrib-python (PyPI) Vendor— Affected before 3.3.1.11 Fixed in 3.3.1.11 Patch available GHSA-w96g-3p64-63wr

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:opencv:opencv:*:*:*:*:*:*:*:*up to 3.3.0VulnerableOpenCV
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
  • cpe:2.3:a:opencv:opencv:*:*:*:*:*:*:*:* Versions up to 3.3.0 Vulnerable ·OpenCV
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-w96g-3p64-63wr opencv-python (PyPI) Fixed in 3.3.1.11 Advisory →
  • Fix · GHSA-w96g-3p64-63wr opencv-contrib-python (PyPI) Fixed in 3.3.1.11 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 6AffectedNo fix planned: Will not fix
Red Hat Enterprise Linux 7AffectedNo fix planned: Will not fix

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-12601
  2. 2026-10-03 Alias added: GHSA-w96g-3p64-63wr

References

Sources