XML external entity injection in Apache NiFi
Priority LOW 33CWE-611Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-611 and the CVSS impact.
Summary
An authorized user could upload a template which contained malicious code and accessed sensitive files via an XML External Entity (XXE) attack. The fix to properly handle XML External Entities was applied on the Apache NiFi 1.4.0 release. Users running a prior 1.x release should upgrade to the appropriate release.
Why it matters now
EPSS 0.0194 80th percentileScored 2026-11-07
Fix Fixed org.apache.nifi:nifi (Maven): 1.4.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache NiFi | 1.0.0 to 1.3.0 | — | No fix listed | CNA |
| — | org.apache.nifi:nifi (Maven) | 1.0.0 to before 1.4.0 | 1.4.0 | Patch available | GHSA-qj7f-j6h9-g5rq |
- Apache NiFi VendorApache Affected 1.0.0 to 1.3.0 Fixed in — No fix listed CNA
- org.apache.nifi:nifi (Maven) Vendor— Affected 1.0.0 to before 1.4.0 Fixed in 1.4.0 Patch available GHSA-qj7f-j6h9-g5rq
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:nifi:1.0.0:*:*:*:*:*:*:* | 1.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:1.0.1:*:*:*:*:*:*:* | 1.0.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:1.1.0:*:*:*:*:*:*:* | 1.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:1.1.1:*:*:*:*:*:*:* | 1.1.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:1.1.2:*:*:*:*:*:*:* | 1.1.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:1.2.0:*:*:*:*:*:*:* | 1.2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:1.3.0:*:*:*:*:*:*:* | 1.3.0 | Vulnerable | Apache |
- cpe:2.3:a:apache:nifi:1.0.0:*:*:*:*:*:*:* Versions 1.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:1.0.1:*:*:*:*:*:*:* Versions 1.0.1 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:1.1.0:*:*:*:*:*:*:* Versions 1.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:1.1.1:*:*:*:*:*:*:* Versions 1.1.1 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:1.1.2:*:*:*:*:*:*:* Versions 1.1.2 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:1.2.0:*:*:*:*:*:*:* Versions 1.2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:1.3.0:*:*:*:*:*:*:* Versions 1.3.0 Vulnerable ·Apache
Remediation
- Fix · GHSA-qj7f-j6h9-g5rq org.apache.nifi:nifi (Maven) Fixed in 1.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-12623
- 2026-10-03 Alias added: GHSA-qj7f-j6h9-g5rq
References
More Apache Nifi vulnerabilities
- TI-2023-17293 Apache NiFi: Potential Code Injection with Database Services using H2 CVSS 3.1HIGH 8.8
- TI-2020-16549 Uncontrolled resource consumption in Eclipse Jetty CVSS 3.1MEDIUM 5.3
- TI-2019-07411 Deserialization of untrusted data in Apache Commons Beanutils CVSS 3.1HIGH 7.3
- TI-2017-11471 Improper input validation in Apache NiFi CVSS 3.0CRITICAL 9.8
- TI-2018-01212 XML external entity injection in Apache NiFi CVSS 3.0CRITICAL 9.8
- TI-2021-03489 Deserialization of untrusted data in jackson-databind CVSS 3.1HIGH 8.1
Sources
- CVE-2017-12623 · CVE Program
- CVE-2017-12623 · NVD
- FIRST EPSS
- GHSA-qj7f-j6h9-g5rq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences