In Django 1.10.x before 1.10.8 and 1.11.x before 1.11.5, HTML autoescaping was disabled…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
In Django 1.10.x before 1.10.8 and 1.11.x before 1.11.5, HTML autoescaping was disabled in a portion of the template for the technical 500 debug page. Given the right circumstances, this allowed a cross-site scripting attack. This vulnerability shouldn't affect most production sites since you shouldn't run with "DEBUG = True" (which makes this page accessible) in your production settings.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | 1.10a1 to before 1.10.8 | 1.10.8 | Patch available | GHSA-9r8w-6x8c-6jr9 |
| — | Django (PyPI) | 1.11a1 to before 1.11.5 | 1.11.5 | Patch available | GHSA-9r8w-6x8c-6jr9 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected 1.10a1 to before 1.10.8 Fixed in 1.10.8 Patch available GHSA-9r8w-6x8c-6jr9
- Django (PyPI) Vendor— Affected 1.11a1 to before 1.11.5 Fixed in 1.11.5 Patch available GHSA-9r8w-6x8c-6jr9
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:1.10.0:*:*:*:*:*:*:* | 1.10.0 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.10.1:*:*:*:*:*:*:* | 1.10.1 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.10.2:*:*:*:*:*:*:* | 1.10.2 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.10.3:*:*:*:*:*:*:* | 1.10.3 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.10.4:*:*:*:*:*:*:* | 1.10.4 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.10.5:*:*:*:*:*:*:* | 1.10.5 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.10.6:*:*:*:*:*:*:* | 1.10.6 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.10.7:*:*:*:*:*:*:* | 1.10.7 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.11.0:*:*:*:*:*:*:* | 1.11.0 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.11.1:*:*:*:*:*:*:* | 1.11.1 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:1.10.0:*:*:*:*:*:*:* Versions 1.10.0 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.10.1:*:*:*:*:*:*:* Versions 1.10.1 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.10.2:*:*:*:*:*:*:* Versions 1.10.2 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.10.3:*:*:*:*:*:*:* Versions 1.10.3 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.10.4:*:*:*:*:*:*:* Versions 1.10.4 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.10.5:*:*:*:*:*:*:* Versions 1.10.5 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.10.6:*:*:*:*:*:*:* Versions 1.10.6 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.10.7:*:*:*:*:*:*:* Versions 1.10.7 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.11.0:*:*:*:*:*:*:* Versions 1.11.0 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.11.1:*:*:*:*:*:*:* Versions 1.11.1 Vulnerable ·djangoproject
Show 3 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:1.11.2:*:*:*:*:*:*:* | 1.11.2 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.11.3:*:*:*:*:*:*:* | 1.11.3 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.11.4:*:*:*:*:*:*:* | 1.11.4 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:1.11.2:*:*:*:*:*:*:* Versions 1.11.2 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.11.3:*:*:*:*:*:*:* Versions 1.11.3 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.11.4:*:*:*:*:*:*:* Versions 1.11.4 Vulnerable ·djangoproject
Remediation
- Fix · GHSA-9r8w-6x8c-6jr9 Django (PyPI) Fixed in 1.10.8 Advisory →
- Fix · GHSA-9r8w-6x8c-6jr9 Django (PyPI) Fixed in 1.11.5 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 17 products
- Red Hat Ceph Storage 1.3
- Red Hat Ceph Storage 2
- Red Hat Enterprise Linux OpenStack Platform 5 (Icehouse)
- Red Hat Enterprise Linux OpenStack Platform 6 (Juno)
- Red Hat Enterprise Linux OpenStack Platform 7 (Kilo)
- Red Hat Enterprise Linux OpenStack Platform 7 (Kilo) Operational Tools
- Red Hat OpenStack Platform 10 (Newton)
- Red Hat OpenStack Platform 10 (Newton) Operational Tools
- Red Hat OpenStack Platform 11 (Ocata)
- Red Hat OpenStack Platform 12 (Pike)
- Red Hat OpenStack Platform 8 (Liberty)
- Red Hat OpenStack Platform 8 (Liberty) Operational Tools
- Red Hat OpenStack Platform 9 (Mitaka)
- Red Hat OpenStack Platform 9 (Mitaka) Operational Tools
- Red Hat Satellite 6
- Red Hat Storage Console 2
- Red Hat Subscription Asset Manager
Timeline
- 2026-10-02 Threatist record created from CVE-2017-12794
- 2026-10-03 Alias added: GHSA-9r8w-6x8c-6jr9
References
Advisory 3
Other 8
- https://github.com/django/django/commit/58e08e80e362db79eb0fd775dc81faad90dca47a
- https://github.com/django/django/commit/e35a0c56086924f331e9422daa266e907a4784cc
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2017-44.yaml
- https://usn.ubuntu.com/3559-1
- https://web.archive.org/web/20170927072701/http://www.securitytracker.com/id/1039264
- https://web.archive.org/web/20200227150819/http://www.securityfocus.com/bid/100643
- https://www.djangoproject.com/weblog/2017/sep/05/security-releases
More djangoproject Django vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2017-12794 · CVE Program
- CVE-2017-12794 · NVD
- FIRST EPSS
- GHSA-9r8w-6x8c-6jr9 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-12794 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences