Read the docs
TI-2017-09527 Aliases CVE-2017-12864GHSA-267x-w5hx-8hjr

In opencv/modules/imgcodecs/src/grfmt_pxm.cpp, function ReadNumber did not checkout the…

Priority MEDIUM 43CWE-190Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 2 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-190 and the CVSS impact.

Summary

In opencv/modules/imgcodecs/src/grfmt_pxm.cpp, function ReadNumber did not checkout the input length, which lead to integer overflow. If the image is from remote, may lead to remote code execution or denial of service. This affects Opencv 3.3 and earlier.

Why it matters now

EPSS 0.02722 86th percentileScored 2026-11-07
Fix Partial opencv-python (PyPI): 3.3.1.11opencv-contrib-python (PyPI): 3.3.1.11Red Hat: 2 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—opencv-python (PyPI)before 3.3.1.113.3.1.11Patch availableGHSA-267x-w5hx-8hjr
—opencv-contrib-python (PyPI)before 3.3.1.113.3.1.11Patch availableGHSA-267x-w5hx-8hjr
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • opencv-python (PyPI) Vendor— Affected before 3.3.1.11 Fixed in 3.3.1.11 Patch available GHSA-267x-w5hx-8hjr
  • opencv-contrib-python (PyPI) Vendor— Affected before 3.3.1.11 Fixed in 3.3.1.11 Patch available GHSA-267x-w5hx-8hjr

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:opencv:opencv:*:*:*:*:*:*:*:*up to 3.3.0VulnerableOpenCV
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
  • cpe:2.3:a:opencv:opencv:*:*:*:*:*:*:*:* Versions up to 3.3.0 Vulnerable ·OpenCV
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-267x-w5hx-8hjr opencv-python (PyPI) Fixed in 3.3.1.11 Advisory →
  • Fix · GHSA-267x-w5hx-8hjr opencv-contrib-python (PyPI) Fixed in 3.3.1.11 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 6Affected—
Red Hat Enterprise Linux 7Affected—

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-12864
  2. 2026-10-03 Alias added: GHSA-267x-w5hx-8hjr

References

Sources