The multiauth module in SimpleSAMLphp 1.14.13 and earlier allows remote attackers to…
Priority LOW 37CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
The multiauth module in SimpleSAMLphp 1.14.13 and earlier allows remote attackers to bypass authentication context restrictions and use an authentication source defined in config/authsources.php via vectors related to improper validation of user input.
Why it matters now
EPSS 0.02368 83rd percentileScored 2026-11-07
Fix Fixed simplesamlphp/simplesamlphp (Packagist): 1.14.14
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | simplesamlphp/simplesamlphp (Packagist) | before 1.14.14 | 1.14.14 | Patch available | GHSA-qc43-78vj-vg7p |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- simplesamlphp/simplesamlphp (Packagist) Vendor— Affected before 1.14.14 Fixed in 1.14.14 Patch available GHSA-qc43-78vj-vg7p
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* | up to 1.14.13 | Vulnerable | simplesamlphp |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* Versions up to 1.14.13 Vulnerable ·simplesamlphp
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-qc43-78vj-vg7p simplesamlphp/simplesamlphp (Packagist) Fixed in 1.14.14 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-12869
- 2026-10-03 Alias added: GHSA-qc43-78vj-vg7p
References
Advisory 3
Other 3
- https://github.com/FriendsOfPHP/security-advisories/blob/master/simplesamlphp/simplesamlphp/CVE-2017-12869.yaml
- https://github.com/simplesamlphp/simplesamlphp
- https://github.com/simplesamlphp/simplesamlphp/blob/de98fc5bb663feea16686ae77958f759b4a7638d/docs/simplesamlphp-changelog-1.x.md?plain=1#L902C64-L902C79
Sources
- CVE-2017-12869 · CVE Program
- CVE-2017-12869 · NVD
- FIRST EPSS
- GHSA-qc43-78vj-vg7p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences