The (1) Htpasswd authentication source in the authcrypt module and (2) SimpleSAML_Session…
Priority LOW 29CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
The (1) Htpasswd authentication source in the authcrypt module and (2) SimpleSAML_Session class in SimpleSAMLphp 1.14.11 and earlier allow remote attackers to conduct timing side-channel attacks by leveraging use of the standard comparison operator to compare secret material against user input.
Why it matters now
EPSS 0.01459 73rd percentileScored 2026-11-07
Fix Fixed simplesamlphp/simplesamlphp (Packagist): 1.15.0-rc1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | simplesamlphp/simplesamlphp (Packagist) | before 1.15.0-rc1 | 1.15.0-rc1 | Patch available | GHSA-v882-949x-6v28 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- simplesamlphp/simplesamlphp (Packagist) Vendor— Affected before 1.15.0-rc1 Fixed in 1.15.0-rc1 Patch available GHSA-v882-949x-6v28
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* | up to 1.14.11 | Vulnerable | simplesamlphp |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
- cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* Versions up to 1.14.11 Vulnerable ·simplesamlphp
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-v882-949x-6v28 simplesamlphp/simplesamlphp (Packagist) Fixed in 1.15.0-rc1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-12872
- 2026-10-03 Alias added: GHSA-v882-949x-6v28
References
Advisory 3
Sources
- CVE-2017-12872 · CVE Program
- CVE-2017-12872 · NVD
- FIRST EPSS
- GHSA-v882-949x-6v28 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences