SimpleSAMLphp 1.7.0 through 1.14.10 might allow attackers to obtain sensitive…
Priority MEDIUM 45CWE-384Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-384.
Summary
SimpleSAMLphp 1.7.0 through 1.14.10 might allow attackers to obtain sensitive information, gain unauthorized access, or have unspecified other impacts by leveraging incorrect persistent NameID generation when an Identity Provider (IdP) is misconfigured.
Why it matters now
EPSS 0.01656 76th percentileScored 2026-11-07
Fix Fixed simplesamlphp/simplesamlphp (Packagist): 1.14.11
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | simplesamlphp/simplesamlphp (Packagist) | 1.7.0 to before 1.14.11 | 1.14.11 | Patch available | GHSA-gp2m-7cfp-h6gf |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- simplesamlphp/simplesamlphp (Packagist) Vendor— Affected 1.7.0 to before 1.14.11 Fixed in 1.14.11 Patch available GHSA-gp2m-7cfp-h6gf
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* | 1.7.0 – 1.14.10 | Vulnerable | simplesamlphp |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* Versions 1.7.0 – 1.14.10 Vulnerable ·simplesamlphp
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-gp2m-7cfp-h6gf simplesamlphp/simplesamlphp (Packagist) Fixed in 1.14.11 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-12873
- 2026-10-03 Alias added: GHSA-gp2m-7cfp-h6gf
References
Patch 2
Advisory 3
Sources
- CVE-2017-12873 · CVE Program
- CVE-2017-12873 · NVD
- FIRST EPSS
- GHSA-gp2m-7cfp-h6gf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences