The InfoCard module 1.0 for SimpleSAMLphp allows attackers to spoof XML messages by…
Priority LOW 35CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
The InfoCard module 1.0 for SimpleSAMLphp allows attackers to spoof XML messages by leveraging an incorrect check of return values in signature validation utilities.
Why it matters now
EPSS 0.01273 70th percentileScored 2026-11-07
Fix Fixed simplesamlphp/simplesamlphp-module-infocard (Packagist): 1.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | simplesamlphp/simplesamlphp-module-infocard (Packagist) | before 1.0.1 | 1.0.1 | Patch available | GHSA-fj28-869x-vv5g |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- simplesamlphp/simplesamlphp-module-infocard (Packagist) Vendor— Affected before 1.0.1 Fixed in 1.0.1 Patch available GHSA-fj28-869x-vv5g
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:infocard_module:1.0:*:*:*:*:simplesamlphp:*:* | 1.0 | Vulnerable | simplesamlphp |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:simplesamlphp:infocard_module:1.0:*:*:*:*:simplesamlphp:*:* Versions 1.0 Vulnerable ·simplesamlphp
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-fj28-869x-vv5g simplesamlphp/simplesamlphp-module-infocard (Packagist) Fixed in 1.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-12874
- 2026-10-03 Alias added: GHSA-fj28-869x-vv5g
References
Advisory 3
Sources
- CVE-2017-12874 · CVE Program
- CVE-2017-12874 · NVD
- FIRST EPSS
- GHSA-fj28-869x-vv5g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences