Read the docs
TI-2017-09541 Aliases CVE-2017-12881GHSA-274r-p6v6-fhh4

Cross-site request forgery (CSRF) vulnerability in the Spring Batch Admin before 1.3.0…

Priority LOW 39CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

Cross-site request forgery (CSRF) vulnerability in the Spring Batch Admin before 1.3.0 allows remote attackers to hijack the authentication of unspecified victims and submit arbitrary requests, such as exploiting the file upload vulnerability.

Why it matters now

EPSS 0.00794 56th percentileScored 2026-11-07
Fix Fixed org.springframework.batch:spring-batch-admin-manager (Maven): 1.3.0.RELEASE

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.springframework.batch:spring-batch-admin-manager (Maven)before 1.3.0.RELEASE1.3.0.RELEASEPatch availableGHSA-274r-p6v6-fhh4
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.springframework.batch:spring-batch-admin-manager (Maven) Vendor— Affected before 1.3.0.RELEASE Fixed in 1.3.0.RELEASE Patch available GHSA-274r-p6v6-fhh4

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:spring_batch_admin_project:spring_batch_admin:*:*:*:*:*:*:*:*up to 1.2.1VulnerableSpring Batch Admin Project
  • cpe:2.3:a:spring_batch_admin_project:spring_batch_admin:*:*:*:*:*:*:*:* Versions up to 1.2.1 Vulnerable ·Spring Batch Admin Project

Remediation

  • Fix · GHSA-274r-p6v6-fhh4 org.springframework.batch:spring-batch-admin-manager (Maven) Fixed in 1.3.0.RELEASE Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-12881
  2. 2026-10-03 Alias added: GHSA-274r-p6v6-fhh4

References

  • TI-2017-09542 Stored Cross-site scripting (XSS) vulnerability in Spring Batch Admin before 1.3.0 allows… CVSS 3.0MEDIUM 5.4

Sources