Cross-site scripting in Symantec Advanced Secure Gateway
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Stored XSS vulnerability in the Symantec Advanced Secure Gateway (ASG) and ProxySG management consoles. A malicious appliance administrator can inject arbitrary JavaScript code in the management console web client application.
Why it matters now
EPSS 0.01037 64th percentileScored 2026-11-07
Fix Fixed Advanced Secure Gateway (ASG) (Symantec Corporation): 6.6.5.14, 6.7.4.107ProxySG (Symantec Corporation): 6.5.10.8, 6.6.5.14, 6.7.4.107
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Symantec | Advanced Secure Gateway (ASG) | 6.6 to before 6.6.5.14; 6.7 to before 6.7.4.107 | 6.6.5.14, 6.7.4.107 | Patch available | CNA |
| Symantec | ProxySG | 6.5 to before 6.5.10.8; 6.6 to before 6.6.5.14; 6.7 to before 6.7.4.107 | 6.5.10.8, 6.6.5.14, 6.7.4.107 | Patch available | CNA |
- Advanced Secure Gateway (ASG) VendorSymantec Affected 6.6 to before 6.6.5.14; 6.7 to before 6.7.4.107 Fixed in 6.6.5.14, 6.7.4.107 Patch available CNA
- ProxySG VendorSymantec Affected 6.5 to before 6.5.10.8; 6.6 to before 6.6.5.14; 6.7 to before 6.7.4.107 Fixed in 6.5.10.8, 6.6.5.14, 6.7.4.107 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:broadcom:advanced_secure_gateway:*:*:*:*:*:*:*:* | 6.6 to before 6.6.5.14; 6.7.3 to before 6.7.3.7; 6.7.4 to before 6.7.4.107 | Vulnerable | Broadcom |
| cpe:2.3:a:broadcom:symantec_proxysg:*:*:*:*:*:*:*:* | 6.5 to before 6.5.10.8; 6.6 to before 6.6.5.14; 6.7.3 to before 6.7.3.7; 6.7.4 to before 6.7.4.107 | Vulnerable | Broadcom |
- cpe:2.3:a:broadcom:advanced_secure_gateway:*:*:*:*:*:*:*:* Versions 6.6 to before 6.6.5.14; 6.7.3 to before 6.7.3.7; 6.7.4 to before 6.7.4.107 Vulnerable ·Broadcom
- cpe:2.3:a:broadcom:symantec_proxysg:*:*:*:*:*:*:*:* Versions 6.5 to before 6.5.10.8; 6.6 to before 6.6.5.14; 6.7.3 to before 6.7.3.7; 6.7.4 to before 6.7.4.107 Vulnerable ·Broadcom
Remediation
- Fix · CNA Advanced Secure Gateway (ASG) (Symantec Corporation) Fixed in 6.6.5.14, 6.7.4.107
- Fix · CNA ProxySG (Symantec Corporation) Fixed in 6.5.10.8, 6.6.5.14, 6.7.4.107
Timeline
- 2026-10-02 Threatist record created from CVE-2017-13678
- 2026-10-03 Alias added: GHSA-ph7c-5vcg-x887
References
More Symantec vulnerabilities
- TI-2017-04157 Command injection in Symantec Messaging Gateway KEVCVSS 3.1HIGH 8.8
- TI-2009-01353 The Intel LANDesk Common Base Agent (CBA) in Symantec Alert Management System 2 (AMS2)… CVSS 2.0HIGH 10.0
- TI-2017-04156 The Symantec Messaging Gateway can encounter an issue of remote code execution, which… CVSS 3.0CRITICAL 10.0
- TI-2012-00284 The management GUI in Symantec Web Gateway 5.0.x before 5.0.3 does not properly restrict… CVSS 2.0HIGH 10.0
- TI-2006-02539 Stack-based buffer overflow in Symantec Antivirus 10.1 and Client Security 3.1 allows… CVSS 2.0HIGH 10.0
- TI-2012-02563 The management console in Symantec Web Gateway 5.0.x before 5.0.3.18 allows remote… CVSS 2.0HIGH 10.0
Sources
- CVE-2017-13678 · CVE Program
- CVE-2017-13678 · NVD
- FIRST EPSS
- GHSA-ph7c-5vcg-x887 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences