Memory corruption in Apple macOS
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-119 and the CVSS impact.
Summary
A memory corruption issue was addressed with improved memory handling. This issue is fixed in macOS High Sierra 10.13.1, Security Update 2017-001 Sierra, and Security Update 2017-004 El Capitan, macOS High Sierra 10.13. A malicious application may be able to elevate privileges.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apple | macOS | before 10.13 | 10.13 | Patch available | CNA |
| Apple | macOS | before 10.13 | 10.13 | Patch available | CNA |
- macOS VendorApple Affected before 10.13 Fixed in 10.13 Patch available CNA
- macOS VendorApple Affected before 10.13 Fixed in 10.13 Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* | 10.11 to before 10.11.6; 10.12 – 10.12.5 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.11.6:-:*:*:*:*:*:* | 10.11.6 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.11.6:security_update_2016-001:*:*:*:*:*:* | 10.11.6 security_update_2016-001 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.11.6:security_update_2016-002:*:*:*:*:*:* | 10.11.6 security_update_2016-002 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.11.6:security_update_2016-003:*:*:*:*:*:* | 10.11.6 security_update_2016-003 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.11.6:security_update_2017-001:*:*:*:*:*:* | 10.11.6 security_update_2017-001 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.11.6:security_update_2017-002:*:*:*:*:*:* | 10.11.6 security_update_2017-002 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.11.6:security_update_2017-003:*:*:*:*:*:* | 10.11.6 security_update_2017-003 | Vulnerable | Apple |
- cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* Versions 10.11 to before 10.11.6; 10.12 – 10.12.5 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.11.6:-:*:*:*:*:*:* Versions 10.11.6 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.11.6:security_update_2016-001:*:*:*:*:*:* Versions 10.11.6 security_update_2016-001 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.11.6:security_update_2016-002:*:*:*:*:*:* Versions 10.11.6 security_update_2016-002 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.11.6:security_update_2016-003:*:*:*:*:*:* Versions 10.11.6 security_update_2016-003 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.11.6:security_update_2017-001:*:*:*:*:*:* Versions 10.11.6 security_update_2017-001 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.11.6:security_update_2017-002:*:*:*:*:*:* Versions 10.11.6 security_update_2017-002 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.11.6:security_update_2017-003:*:*:*:*:*:* Versions 10.11.6 security_update_2017-003 Vulnerable ·Apple
Remediation
- Fix · CNA macOS (Apple) Fixed in 10.13
- Fix · CNA macOS (Apple) Fixed in 10.13
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apple macOS 10.13
10 records Highest priority Priority LOW 10 LOW
Other records, highest priority first
- TI-2017-10158 Race condition in Apple watchOSPriority LOW 37
- TI-2018-03252 NULL pointer dereference in Apple iOSPriority LOW 36
- TI-2017-10155 An issue existed in the handling of Contact sharing.Priority LOW 35
Timeline
- 2026-10-02 Threatist record created from CVE-2017-13906
- 2026-10-03 Alias added: GHSA-m3pq-c5jj-f5gj
- 2026-10-25 EPSS moved to the 50th–90th percentile
References
More Apple Mac Os X vulnerabilities
- TI-2021-01573 Apple iOS and iPadOS: A remote attacker may be able to cause arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2021-01572 Apple iOS and iPadOS: A remote attacker may be able to cause arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-01607 sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI… KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02117 Out-of-bounds write in Google Chrome KEVCVSS 3.1HIGH 8.8
Sources
- CVE-2017-13906 · CVE Program
- CVE-2017-13906 · NVD
- FIRST EPSS
- GHSA-m3pq-c5jj-f5gj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences