A Remote Code Execution vulnerability has been found in the Horde_Image library when…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA.
Summary
A Remote Code Execution vulnerability has been found in the Horde_Image library when using the "Im" backend that utilizes ImageMagick's "convert" utility. It's not exploitable through any Horde application, because the code path to the vulnerability is not used by any Horde code. Custom applications using the Horde_Image library might be affected. This vulnerability affects all versions of Horde_Image from 2.0.0 to 2.5.1, and is fixed in 2.5.2. The problem is missing input validation of the index field in _raw() during construction of an ImageMagick command line.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 26
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:horde:horde_image_api:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.0.0:alpha1:*:*:*:*:*:* | 2.0.0 alpha1 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.0.0:beta1:*:*:*:*:*:* | 2.0.0 beta1 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.0.0:beta2:*:*:*:*:*:* | 2.0.0 beta2 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.0.2:*:*:*:*:*:*:* | 2.0.2 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.0.3:*:*:*:*:*:*:* | 2.0.3 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.0.4:*:*:*:*:*:*:* | 2.0.4 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.0.5:*:*:*:*:*:*:* | 2.0.5 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.0.6:*:*:*:*:*:*:* | 2.0.6 | Vulnerable | Horde |
- cpe:2.3:a:horde:horde_image_api:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.0.0:alpha1:*:*:*:*:*:* Versions 2.0.0 alpha1 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.0.0:beta1:*:*:*:*:*:* Versions 2.0.0 beta1 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.0.0:beta2:*:*:*:*:*:* Versions 2.0.0 beta2 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.0.2:*:*:*:*:*:*:* Versions 2.0.2 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.0.3:*:*:*:*:*:*:* Versions 2.0.3 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.0.4:*:*:*:*:*:*:* Versions 2.0.4 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.0.5:*:*:*:*:*:*:* Versions 2.0.5 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.0.6:*:*:*:*:*:*:* Versions 2.0.6 Vulnerable ·Horde
Show 16 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:horde:horde_image_api:2.0.7:*:*:*:*:*:*:* | 2.0.7 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.0.8:*:*:*:*:*:*:* | 2.0.8 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.0.9:*:*:*:*:*:*:* | 2.0.9 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.1.0:*:*:*:*:*:*:* | 2.1.0 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.2.0:*:*:*:*:*:*:* | 2.2.0 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.3.0:*:*:*:*:*:*:* | 2.3.0 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.3.1:*:*:*:*:*:*:* | 2.3.1 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.3.2:*:*:*:*:*:*:* | 2.3.2 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.3.3:*:*:*:*:*:*:* | 2.3.3 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.3.4:*:*:*:*:*:*:* | 2.3.4 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.3.5:*:*:*:*:*:*:* | 2.3.5 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.3.6:*:*:*:*:*:*:* | 2.3.6 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.4.0:*:*:*:*:*:*:* | 2.4.0 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.4.1:*:*:*:*:*:*:* | 2.4.1 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.5.0:*:*:*:*:*:*:* | 2.5.0 | Vulnerable | Horde |
| cpe:2.3:a:horde:horde_image_api:2.5.1:*:*:*:*:*:*:* | 2.5.1 | Vulnerable | Horde |
- cpe:2.3:a:horde:horde_image_api:2.0.7:*:*:*:*:*:*:* Versions 2.0.7 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.0.8:*:*:*:*:*:*:* Versions 2.0.8 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.0.9:*:*:*:*:*:*:* Versions 2.0.9 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.3.0:*:*:*:*:*:*:* Versions 2.3.0 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.3.1:*:*:*:*:*:*:* Versions 2.3.1 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.3.2:*:*:*:*:*:*:* Versions 2.3.2 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.3.3:*:*:*:*:*:*:* Versions 2.3.3 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.3.4:*:*:*:*:*:*:* Versions 2.3.4 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.3.5:*:*:*:*:*:*:* Versions 2.3.5 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.3.6:*:*:*:*:*:*:* Versions 2.3.6 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.4.0:*:*:*:*:*:*:* Versions 2.4.0 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.4.1:*:*:*:*:*:*:* Versions 2.4.1 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·Horde
- cpe:2.3:a:horde:horde_image_api:2.5.1:*:*:*:*:*:*:* Versions 2.5.1 Vulnerable ·Horde
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2017-14650
- 2026-10-03 Alias added: GHSA-fxvw-26c8-9g9m
References
More Horde Image Api vulnerabilities
- TI-2017-07156 Remote Code Execution was found in Horde_Image 2.x before 2.5.0 via a crafted GET request. CVSS 3.0HIGH 8.8
Sources
- CVE-2017-14650 · CVE Program
- CVE-2017-14650 · NVD
- FIRST EPSS
- GHSA-fxvw-26c8-9g9m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences