Multiple buffer overflow vulnerabilities exist in the HTTPd server in Asus asuswrt…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-119 and the CVSS impact.
Summary
Multiple buffer overflow vulnerabilities exist in the HTTPd server in Asus asuswrt version <=3.0.0.4.376.X. All have been fixed in version 3.0.0.4.378, but this vulnerability was not previously disclosed. Some end-of-life routers have this version as the newest and thus are vulnerable at this time. This vulnerability allows for RCE with administrator rights when the administrator visits several pages.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2017-15655
- 2026-10-03 Alias added: GHSA-w6cp-hqm8-4phj
References
More Asuswrt vulnerabilities
- TI-2018-04367 An issue was discovered in AsusWRT before 3.0.0.4.384_10007. CVSS 3.0CRITICAL 9.8
- TI-2018-04368 An issue was discovered in AsusWRT before 3.0.0.4.384_10007. CVSS 3.0CRITICAL 9.8
- TI-2022-09749 Out-of-bounds write in Asuswrt-Merlin New Gen CVSS 3.1CRITICAL 9.8
- TI-2018-14391 An issue was discovered in ASUSWRT 3.0.0.4.384.20308. CVSS 3.1CRITICAL 9.8
- TI-2017-11444 Improper administrator IP validation after his login in the HTTPd server in all current… CVSS 3.0HIGH 8.8
- TI-2017-11447 Password are stored in plaintext in nvram in the HTTPd server in all current versions (<=… CVSS 3.0HIGH 8.8
Sources
- CVE-2017-15655 · CVE Program
- CVE-2017-15655 · NVD
- FIRST EPSS
- GHSA-w6cp-hqm8-4phj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences