Path traversal in Apache Oozie
Priority LOW 34CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
Vulnerability allows a user of Apache Oozie 3.1.3-incubating to 4.3.0 and 5.0.0-beta1 to expose private files on the Oozie server process. The malicious user can construct a workflow XML file containing XML directives and configuration that reference sensitive files on the Oozie server host.
Why it matters now
EPSS 0.02496 84th percentileScored 2026-11-07
Fix Fixed org.apache.oozie:oozie-core (Maven): 5.0.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Oozie | 3.1.3-incubating to 4.3.0; 5.0.0-beta1 | — | No fix listed | CNA |
| — | org.apache.oozie:oozie-core (Maven) | 3.1.3 to before 5.0.0 | 5.0.0 | Patch available | GHSA-2fx6-r6qx-3c7h |
- Apache Oozie VendorApache Affected 3.1.3-incubating to 4.3.0; 5.0.0-beta1 Fixed in — No fix listed CNA
- org.apache.oozie:oozie-core (Maven) Vendor— Affected 3.1.3 to before 5.0.0 Fixed in 5.0.0 Patch available GHSA-2fx6-r6qx-3c7h
CPE configurations NVD · 29
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:oozie:3.1.2:*:*:*:*:*:*:* | 3.1.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:3.1.3:*:*:*:*:*:*:* | 3.1.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:3.2:*:*:*:*:*:*:* | 3.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:3.2.0:*:*:*:*:*:*:* | 3.2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:3.2.0:incubating:*:*:*:*:*:* | 3.2.0 incubating | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:3.3.0:*:*:*:*:*:*:* | 3.3.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:3.3.0:rc0:*:*:*:*:*:* | 3.3.0 rc0 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:3.3.0:rc1:*:*:*:*:*:* | 3.3.0 rc1 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:3.3.1:*:*:*:*:*:*:* | 3.3.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:3.3.1:rc0:*:*:*:*:*:* | 3.3.1 rc0 | Vulnerable | Apache |
- cpe:2.3:a:apache:oozie:3.1.2:*:*:*:*:*:*:* Versions 3.1.2 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:3.1.3:*:*:*:*:*:*:* Versions 3.1.3 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:3.2:*:*:*:*:*:*:* Versions 3.2 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:3.2.0:*:*:*:*:*:*:* Versions 3.2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:3.2.0:incubating:*:*:*:*:*:* Versions 3.2.0 incubating Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:3.3.0:*:*:*:*:*:*:* Versions 3.3.0 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:3.3.0:rc0:*:*:*:*:*:* Versions 3.3.0 rc0 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:3.3.0:rc1:*:*:*:*:*:* Versions 3.3.0 rc1 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:3.3.1:*:*:*:*:*:*:* Versions 3.3.1 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:3.3.1:rc0:*:*:*:*:*:* Versions 3.3.1 rc0 Vulnerable ·Apache
Show 19 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:oozie:3.3.1:rc1:*:*:*:*:*:* | 3.3.1 rc1 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:3.3.2:*:*:*:*:*:*:* | 3.3.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:3.3.2:rc0:*:*:*:*:*:* | 3.3.2 rc0 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:4.0.0:*:*:*:*:*:*:* | 4.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:4.0.0:rc0:*:*:*:*:*:* | 4.0.0 rc0 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:4.0.0:rc1:*:*:*:*:*:* | 4.0.0 rc1 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:4.0.0:rc3:*:*:*:*:*:* | 4.0.0 rc3 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:4.0.1:*:*:*:*:*:*:* | 4.0.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:4.0.1:rc0:*:*:*:*:*:* | 4.0.1 rc0 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:4.0.1:rc1:*:*:*:*:*:* | 4.0.1 rc1 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:4.1.0:*:*:*:*:*:*:* | 4.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:4.1.0:rc0:*:*:*:*:*:* | 4.1.0 rc0 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:4.1.0:rc1:*:*:*:*:*:* | 4.1.0 rc1 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:4.2.0:*:*:*:*:*:*:* | 4.2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:4.2.0:rc0:*:*:*:*:*:* | 4.2.0 rc0 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:4.3.0:*:*:*:*:*:*:* | 4.3.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:4.3.0:rc0:*:*:*:*:*:* | 4.3.0 rc0 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:4.3.0:rc1:*:*:*:*:*:* | 4.3.0 rc1 | Vulnerable | Apache |
| cpe:2.3:a:apache:oozie:5.0.0:beta1:*:*:*:*:*:* | 5.0.0 beta1 | Vulnerable | Apache |
- cpe:2.3:a:apache:oozie:3.3.1:rc1:*:*:*:*:*:* Versions 3.3.1 rc1 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:3.3.2:*:*:*:*:*:*:* Versions 3.3.2 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:3.3.2:rc0:*:*:*:*:*:* Versions 3.3.2 rc0 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:4.0.0:*:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:4.0.0:rc0:*:*:*:*:*:* Versions 4.0.0 rc0 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:4.0.0:rc1:*:*:*:*:*:* Versions 4.0.0 rc1 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:4.0.0:rc3:*:*:*:*:*:* Versions 4.0.0 rc3 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:4.0.1:*:*:*:*:*:*:* Versions 4.0.1 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:4.0.1:rc0:*:*:*:*:*:* Versions 4.0.1 rc0 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:4.0.1:rc1:*:*:*:*:*:* Versions 4.0.1 rc1 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:4.1.0:*:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:4.1.0:rc0:*:*:*:*:*:* Versions 4.1.0 rc0 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:4.1.0:rc1:*:*:*:*:*:* Versions 4.1.0 rc1 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:4.2.0:*:*:*:*:*:*:* Versions 4.2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:4.2.0:rc0:*:*:*:*:*:* Versions 4.2.0 rc0 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:4.3.0:*:*:*:*:*:*:* Versions 4.3.0 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:4.3.0:rc0:*:*:*:*:*:* Versions 4.3.0 rc0 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:4.3.0:rc1:*:*:*:*:*:* Versions 4.3.0 rc1 Vulnerable ·Apache
- cpe:2.3:a:apache:oozie:5.0.0:beta1:*:*:*:*:*:* Versions 5.0.0 beta1 Vulnerable ·Apache
Remediation
- Fix · GHSA-2fx6-r6qx-3c7h org.apache.oozie:oozie-core (Maven) Fixed in 5.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-15712
- 2026-10-03 Alias added: GHSA-2fx6-r6qx-3c7h
References
More Apache Oozie vulnerabilities
- TI-2018-08453 Improper input validation in Apache Oozie CVSS 3.0MEDIUM 6.5
- TI-2025-19709 Apache Oozie: XSS in Oozie Web Console CVSS 3.1MEDIUM 5.4
- TI-2020-17980 Oozie local privilege escalation CVSS 3.1MEDIUM 4.7
Sources
- CVE-2017-15712 · CVE Program
- CVE-2017-15712 · NVD
- FIRST EPSS
- GHSA-2fx6-r6qx-3c7h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences