Cross-site scripting in HackerOne forms node module
Priority LOW 29CWE-80Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-80.
Summary
Forms is a library for easily creating HTML forms. Versions before 1.3.0 did not have proper html escaping. This means that if the application did not sanitize html on behalf of forms, use of forms may be vulnerable to cross site scripting
Why it matters now
EPSS 0.00835 57th percentileScored 2026-11-07
Fix Fixed forms node module (HackerOne): 1.3.0forms (npm): 1.3.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | forms node module | before 1.3.0 | 1.3.0 | Patch available | CNA |
| — | forms (npm) | before 1.3.0 | 1.3.0 | Patch available | GHSA-vwjj-2852-3765 |
- forms node module VendorHackerOne Affected before 1.3.0 Fixed in 1.3.0 Patch available CNA
- forms (npm) Vendor— Affected before 1.3.0 Fixed in 1.3.0 Patch available GHSA-vwjj-2852-3765
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:forms_project:forms:*:*:*:*:*:node.js:*:* | before 1.3.0 | Vulnerable | Forms Project |
- cpe:2.3:a:forms_project:forms:*:*:*:*:*:node.js:*:* Versions before 1.3.0 Vulnerable ·Forms Project
Remediation
- Fix · CNA forms node module (HackerOne) Fixed in 1.3.0
- Fix · GHSA-vwjj-2852-3765 forms (npm) Fixed in 1.3.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-16015
- 2026-10-03 Alias added: GHSA-vwjj-2852-3765
References
More Forms Project Forms vulnerabilities
- TI-2021-06081 Regular expression denial of service (ReDoS) in forms CVSS 3.1MEDIUM 5.3
Sources
- CVE-2017-16015 · CVE Program
- CVE-2017-16015 · NVD
- FIRST EPSS
- GHSA-vwjj-2852-3765 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences