Uncontrolled resource consumption in HackerOne decamelize node module
Priority LOW 36CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
Decamelize is used to convert a dash/dot/underscore/space separated string to camelCase. Decamelize 1.1.0 through 1.1.1 uses regular expressions to evaluate a string and takes unescaped separator values, which can be used to create a denial of service attack.
Why it matters now
EPSS 0.01433 73rd percentileScored 2026-11-07
Fix Fixed decamelize (npm): 1.1.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | decamelize node module | >=1.1.0 <=1.1.1 | — | No fix listed | CNA |
| — | decamelize (npm) | 1.1.0 to before 1.1.2 | 1.1.2 | Patch available | GHSA-q5c4-39f5-m68j |
- decamelize node module VendorHackerOne Affected >=1.1.0 <=1.1.1 Fixed in — No fix listed CNA
- decamelize (npm) Vendor— Affected 1.1.0 to before 1.1.2 Fixed in 1.1.2 Patch available GHSA-q5c4-39f5-m68j
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:decamelize_project:decamelize:1.1.0:*:*:*:*:*:*:* | 1.1.0 | Vulnerable | Decamelize Project |
| cpe:2.3:a:decamelize_project:decamelize:1.1.1:*:*:*:*:*:*:* | 1.1.1 | Vulnerable | Decamelize Project |
- cpe:2.3:a:decamelize_project:decamelize:1.1.0:*:*:*:*:*:*:* Versions 1.1.0 Vulnerable ·Decamelize Project
- cpe:2.3:a:decamelize_project:decamelize:1.1.1:*:*:*:*:*:*:* Versions 1.1.1 Vulnerable ·Decamelize Project
Remediation
- Fix · GHSA-q5c4-39f5-m68j decamelize (npm) Fixed in 1.1.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 3 products
- Red Hat Mobile Application Platform 4
- Red Hat OpenShift Enterprise 3
- Red Hat Software Collections
Timeline
- 2026-10-02 Threatist record created from CVE-2017-16023
- 2026-10-03 Alias added: GHSA-q5c4-39f5-m68j
References
Sources
- CVE-2017-16023 · CVE Program
- CVE-2017-16023 · NVD
- FIRST EPSS
- GHSA-q5c4-39f5-m68j · GitHub Advisory Database · CC BY 4.0
- CVE-2017-16023 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences