Improper input validation in HackerOne request node module
Priority LOW 31CWE-201Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-201.
Summary
Request is an http client. If a request is made using ```multipart```, and the body type is a ```number```, then the specified number of non-zero memory is passed in the body. This affects Request >=2.2.6 <2.47.0 || >2.51.0 <=2.67.0.
Why it matters now
EPSS 0.02584 85th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD
Fix Partial request (npm): 2.68.0Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | request node module | >=2.2.6 <2.47.0 || >2.51.0 <=2.67.0 | — | No fix listed | CNA |
| — | request (npm) | 2.49.0 to before 2.68.0 | 2.68.0 | Patch available | GHSA-7xfp-9c55-5vqj |
| — | request (npm) | 2.2.6 to before 2.68.0 | 2.68.0 | Patch available | GHSA-7xfp-9c55-5vqj |
- request node module VendorHackerOne Affected >=2.2.6 <2.47.0 || >2.51.0 <=2.67.0 Fixed in — No fix listed CNA
- request (npm) Vendor— Affected 2.49.0 to before 2.68.0 Fixed in 2.68.0 Patch available GHSA-7xfp-9c55-5vqj
- request (npm) Vendor— Affected 2.2.6 to before 2.68.0 Fixed in 2.68.0 Patch available GHSA-7xfp-9c55-5vqj
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:request_project:request:*:*:*:*:*:node.js:*:* | 2.2.6 to before 2.47.0; after 2.51.0, up to 2.67.0 | Vulnerable | Request Project |
- cpe:2.3:a:request_project:request:*:*:*:*:*:node.js:*:* Versions 2.2.6 to before 2.47.0; after 2.51.0, up to 2.67.0 Vulnerable ·Request Project
Remediation
- Fix · GHSA-7xfp-9c55-5vqj request (npm) Fixed in 2.68.0 Advisory →
- Fix · GHSA-7xfp-9c55-5vqj request (npm) Fixed in 2.68.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Will not fix |
Not affected: 3 products
- Red Hat Mobile Application Platform 4
- Red Hat OpenShift Enterprise 3
- Red Hat Software Collections
Timeline
- 2026-10-02 Threatist record created from CVE-2017-16026
- 2026-10-03 Alias added: GHSA-7xfp-9c55-5vqj
References
Exploit 3
More Request Project Request vulnerabilities
- TI-2023-12726 The Request package through 2.88.1 for Node.js allows a bypass of SSRF mitigations via an… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2017-16026 · CVE Program
- CVE-2017-16026 · NVD
- FIRST EPSS
- GHSA-7xfp-9c55-5vqj · GitHub Advisory Database · CC BY 4.0
- CVE-2017-16026 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences