Code injection in HackerOne growl node module
Priority MEDIUM 49CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Growl adds growl notification support to nodejs. Growl before 1.10.2 does not properly sanitize input before passing it to exec, allowing for arbitrary command execution.
Why it matters now
EPSS 0.04581 91st percentileScored 2026-11-07
Fix Fixed growl node module (HackerOne): 1.10.2growl (npm): 1.10.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | growl node module | before 1.10.2 | 1.10.2 | Patch available | CNA |
| — | growl (npm) | before 1.10.0 | 1.10.0 | Patch available | GHSA-qh2h-chj9-jffq |
- growl node module VendorHackerOne Affected before 1.10.2 Fixed in 1.10.2 Patch available CNA
- growl (npm) Vendor— Affected before 1.10.0 Fixed in 1.10.0 Patch available GHSA-qh2h-chj9-jffq
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:growl_project:growl:*:*:*:*:*:node.js:*:* | before 1.10.2 | Vulnerable | Growl Project |
- cpe:2.3:a:growl_project:growl:*:*:*:*:*:node.js:*:* Versions before 1.10.2 Vulnerable ·Growl Project
Remediation
- Fix · CNA growl node module (HackerOne) Fixed in 1.10.2
- Fix · GHSA-qh2h-chj9-jffq growl (npm) Fixed in 1.10.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat Mobile Application Platform 4
- Red Hat Virtualization 4
Timeline
- 2026-10-02 Threatist record created from CVE-2017-16042
- 2026-10-03 Alias added: GHSA-qh2h-chj9-jffq
References
Advisory 3
Sources
- CVE-2017-16042 · CVE Program
- CVE-2017-16042 · NVD
- FIRST EPSS
- GHSA-qh2h-chj9-jffq · GitHub Advisory Database · CC BY 4.0
- CVE-2017-16042 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences