Read the docs
TI-2017-11855 Aliases CVE-2017-16136GHSA-qx2f-477c-35rq

Uncontrolled resource consumption in HackerOne method-override node module

Priority LOW 35CWE-400Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-400.

Summary

method-override is a module used by the Express.js framework to let you use HTTP verbs such as PUT or DELETE in places where the client doesn't support it. method-override is vulnerable to a regular expression denial of service vulnerability when specially crafted input is passed in to be parsed via the X-HTTP-Method-Override header.

Why it matters now

EPSS 0.01196 68th percentileScored 2026-11-07
Fix Fixed method-override (npm): 2.3.10

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
HackerOnemethod-override node module<= 1.0.2 || > 2.0.0 < 2.3.10—No fix listedCNA
—method-override (npm)1.0.2 to before 2.3.102.3.10Patch availableGHSA-qx2f-477c-35rq
—method-override (npm)2.0.0 to before 2.3.102.3.10Patch availableGHSA-qx2f-477c-35rq
  • method-override node module VendorHackerOne Affected <= 1.0.2 || > 2.0.0 < 2.3.10 Fixed in — No fix listed CNA
  • method-override (npm) Vendor— Affected 1.0.2 to before 2.3.10 Fixed in 2.3.10 Patch available GHSA-qx2f-477c-35rq
  • method-override (npm) Vendor— Affected 2.0.0 to before 2.3.10 Fixed in 2.3.10 Patch available GHSA-qx2f-477c-35rq

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:expressjs:method-override:*:*:*:*:*:node.js:*:*before 2.3.10Vulnerableexpressjs
  • cpe:2.3:a:expressjs:method-override:*:*:*:*:*:node.js:*:* Versions before 2.3.10 Vulnerable ·expressjs

Remediation

  • Fix · GHSA-qx2f-477c-35rq method-override (npm) Fixed in 2.3.10 Advisory →
  • Fix · GHSA-qx2f-477c-35rq method-override (npm) Fixed in 2.3.10 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat Mobile Application Platform 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-16136
  2. 2026-10-03 Alias added: GHSA-qx2f-477c-35rq

References

Sources