In the yajl-ruby gem 1.3.0 for Ruby, when a crafted JSON file is supplied to…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 8 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-134 and the CVSS impact.
Summary
In the yajl-ruby gem 1.3.0 for Ruby, when a crafted JSON file is supplied to Yajl::Parser.new.parse, the whole ruby process crashes with a SIGABRT in the yajl_string_decode function in yajl_encode.c. This results in the whole ruby process terminating and potentially a denial of service.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | yajl-ruby (RubyGems) | before 1.3.1 | 1.3.1 | Patch available | GHSA-wwh7-4jw9-33x6 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- yajl-ruby (RubyGems) Vendor— Affected before 1.3.1 Fixed in 1.3.1 Patch available GHSA-wwh7-4jw9-33x6
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:yajl-ruby_project:yajl-ruby:1.3.0:*:*:*:*:ruby:*:* | 1.3.0 | Vulnerable | Yajl-ruby Project |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
- cpe:2.3:a:yajl-ruby_project:yajl-ruby:1.3.0:*:*:*:*:ruby:*:* Versions 1.3.0 Vulnerable ·Yajl-ruby Project
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-wwh7-4jw9-33x6 yajl-ruby (RubyGems) Fixed in 1.3.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux OpenStack Platform 7 (Kilo) Operational Tools | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 10 (Newton) Operational Tools | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 11 (Ocata) Operational Tools | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 12 (Pike) Operational Tools | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 13 (Queens) Operational Tools | Affected | No fix yet |
| Red Hat OpenStack Platform 8 (Liberty) Operational Tools | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 9 (Mitaka) Operational Tools | Affected | No fix planned: Will not fix |
| Red Hat Virtualization 4 | Affected | No fix planned: Will not fix |
Not affected: 1 product
- Red Hat OpenShift Enterprise 3
Timeline
- 2026-10-02 Threatist record created from CVE-2017-16516
- 2026-10-03 Alias added: GHSA-wwh7-4jw9-33x6
- 2026-10-31 EPSS moved to the 90th–95th percentile
- 2026-11-06 EPSS moved to the 50th–90th percentile
References
Advisory 3
Other 7
- [debian-lts-announce] 20230711 [SECURITY] [DLA 3492-1] yajl security update
- [debian-lts-announce] 20230805 [SECURITY] [DLA 3516-1] burp security update
- https://github.com/brianmario/yajl-ruby/pull/178
- https://github.com/github/advisory-database/pull/2158
- https://github.com/brianmario/yajl-ruby/commit/a8ca8f476655adaa187eedc60bdc770fff3c51ce
- https://github.com/brianmario/yajl-ruby
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/yajl-ruby/CVE-2017-16516.yml
Sources
- CVE-2017-16516 · CVE Program
- CVE-2017-16516 · NVD
- FIRST EPSS
- GHSA-wwh7-4jw9-33x6 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-16516 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences