Read the docs
TI-2017-12224 Aliases CVE-2017-16613GHSA-qhq8-xwqv-pvv9

An issue was discovered in middleware.py in OpenStack Swauth through 1.2.0 when used with…

Priority MEDIUM 53CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.

Summary

An issue was discovered in middleware.py in OpenStack Swauth through 1.2.0 when used with OpenStack Swift through 2.15.1. The Swift object store and proxy server are saving (unhashed) tokens retrieved from the Swauth middleware authentication mechanism to a log file as part of a GET URI. This allows attackers to bypass authentication by inserting a token into an X-Auth-Token header of a new request. NOTE: github.com/openstack/swauth URLs do not mean that Swauth is maintained by an official OpenStack project team.

Why it matters now

EPSS 0.08582 95th percentileScored 2026-11-07
Fix Fixed swauth (PyPI): 1.3.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—swauth (PyPI)before 1.3.01.3.0Patch availableGHSA-qhq8-xwqv-pvv9
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • swauth (PyPI) Vendor— Affected before 1.3.0 Fixed in 1.3.0 Patch available GHSA-qhq8-xwqv-pvv9

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:openstack:swauth:*:*:*:*:*:*:*:*up to 1.2.0VulnerableOpenStack
cpe:2.3:a:openstack:swift:*:*:*:*:*:*:*:*up to 2.15.1VulnerableOpenStack
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
  • cpe:2.3:a:openstack:swauth:*:*:*:*:*:*:*:* Versions up to 1.2.0 Vulnerable ·OpenStack
  • cpe:2.3:a:openstack:swift:*:*:*:*:*:*:*:* Versions up to 2.15.1 Vulnerable ·OpenStack
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-qhq8-xwqv-pvv9 swauth (PyPI) Fixed in 1.3.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-16613
  2. 2026-10-03 Alias added: GHSA-qhq8-xwqv-pvv9
  3. 2026-11-04 EPSS moved to the 95th–99th percentile

References

Sources