An exploitable vulnerability exists in the YAML parsing functionality in the…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
An exploitable vulnerability exists in the YAML parsing functionality in the parse_yaml_query method in parser.py in MLAlchemy before 0.2.2. When processing YAML-Based queries for data, a YAML parser can execute arbitrary Python commands resulting in command execution because load is used where safe_load should have been used. An attacker can insert Python into loaded YAML to trigger this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | MLAlchemy (PyPI) | before 0.2.2 | 0.2.2 | Patch available | GHSA-xpm8-98mx-h4c5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- MLAlchemy (PyPI) Vendor— Affected before 0.2.2 Fixed in 0.2.2 Patch available GHSA-xpm8-98mx-h4c5
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mlalchemy_project:mlalchemy:0.1.1:*:*:*:*:*:*:* | 0.1.1 | Vulnerable | Mlalchemy Project |
| cpe:2.3:a:mlalchemy_project:mlalchemy:0.1.2:*:*:*:*:*:*:* | 0.1.2 | Vulnerable | Mlalchemy Project |
| cpe:2.3:a:mlalchemy_project:mlalchemy:0.1.3:*:*:*:*:*:*:* | 0.1.3 | Vulnerable | Mlalchemy Project |
| cpe:2.3:a:mlalchemy_project:mlalchemy:0.2.0:*:*:*:*:*:*:* | 0.2.0 | Vulnerable | Mlalchemy Project |
| cpe:2.3:a:mlalchemy_project:mlalchemy:0.2.1:*:*:*:*:*:*:* | 0.2.1 | Vulnerable | Mlalchemy Project |
- cpe:2.3:a:mlalchemy_project:mlalchemy:0.1.1:*:*:*:*:*:*:* Versions 0.1.1 Vulnerable ·Mlalchemy Project
- cpe:2.3:a:mlalchemy_project:mlalchemy:0.1.2:*:*:*:*:*:*:* Versions 0.1.2 Vulnerable ·Mlalchemy Project
- cpe:2.3:a:mlalchemy_project:mlalchemy:0.1.3:*:*:*:*:*:*:* Versions 0.1.3 Vulnerable ·Mlalchemy Project
- cpe:2.3:a:mlalchemy_project:mlalchemy:0.2.0:*:*:*:*:*:*:* Versions 0.2.0 Vulnerable ·Mlalchemy Project
- cpe:2.3:a:mlalchemy_project:mlalchemy:0.2.1:*:*:*:*:*:*:* Versions 0.2.1 Vulnerable ·Mlalchemy Project
Remediation
- Fix · GHSA-xpm8-98mx-h4c5 MLAlchemy (PyPI) Fixed in 0.2.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-16615
- 2026-10-03 Alias added: GHSA-xpm8-98mx-h4c5
References
Advisory 2
Other 5
- https://github.com/thanethomson/MLAlchemy/commit/bc795757febdcce430d89f9d08f75c32d6989d3c
- https://github.com/thanethomson/MLAlchemy/issues/1
- https://github.com/pypa/advisory-database/tree/main/vulns/mlalchemy/PYSEC-2017-19.yaml
- https://github.com/thanethomson/MLAlchemy
- https://joel-malwarebenchmark.github.io/blog/2017/11/08/cve-2017-16615-critical-restful-web-applications-vulnerability
Sources
- CVE-2017-16615 · CVE Program
- CVE-2017-16615 · NVD
- FIRST EPSS
- GHSA-xpm8-98mx-h4c5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences