Read the docs
TI-2017-12227 Aliases CVE-2017-16616GHSA-vg8g-jpm9-jh8r

An exploitable vulnerability exists in the YAML parsing functionality in the YAMLParser…

Priority MEDIUM 48CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.

Summary

An exploitable vulnerability exists in the YAML parsing functionality in the YAMLParser method in Interfaces.py in PyAnyAPI before 0.6.1. A YAML parser can execute arbitrary Python commands resulting in command execution because load is used where safe_load should have been used. An attacker can insert Python into loaded YAML to trigger this vulnerability.

Why it matters now

EPSS 0.0362 89th percentileScored 2026-11-07
Fix Fixed pyanyapi (PyPI): 0.6.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—pyanyapi (PyPI)before 0.6.10.6.1Patch availableGHSA-vg8g-jpm9-jh8r
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • pyanyapi (PyPI) Vendor— Affected before 0.6.1 Fixed in 0.6.1 Patch available GHSA-vg8g-jpm9-jh8r

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pyanyapi_project:pyanyapi:*:*:*:*:*:*:*:*before 0.6.1VulnerablePyanyapi Project
  • cpe:2.3:a:pyanyapi_project:pyanyapi:*:*:*:*:*:*:*:* Versions before 0.6.1 Vulnerable ·Pyanyapi Project

Remediation

  • Fix · GHSA-vg8g-jpm9-jh8r pyanyapi (PyPI) Fixed in 0.6.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-16616
  2. 2026-10-03 Alias added: GHSA-vg8g-jpm9-jh8r

References

Sources