An exploitable vulnerability exists in the YAML loading functionality of util.py in…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
An exploitable vulnerability exists in the YAML loading functionality of util.py in OwlMixin before 2.0.0a12. A "Load YAML" string or file (aka load_yaml or load_yamlf) can execute arbitrary Python commands resulting in command execution because load is used where safe_load should have been used. An attacker can insert Python into loaded YAML to trigger this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | owlmixin (PyPI) | before 2.0.0 | 2.0.0 | Patch available | GHSA-ccmq-qvcp-5mrm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- owlmixin (PyPI) Vendor— Affected before 2.0.0 Fixed in 2.0.0 Patch available GHSA-ccmq-qvcp-5mrm
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:owlmixin_project:owlmixin:*:*:*:*:*:*:*:* | before 2.0.0 | Vulnerable | Owlmixin Project |
| cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha1:*:*:*:*:*:* | 2.0.0 alpha1 | Vulnerable | Owlmixin Project |
| cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha10:*:*:*:*:*:* | 2.0.0 alpha10 | Vulnerable | Owlmixin Project |
| cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha11:*:*:*:*:*:* | 2.0.0 alpha11 | Vulnerable | Owlmixin Project |
| cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha2:*:*:*:*:*:* | 2.0.0 alpha2 | Vulnerable | Owlmixin Project |
| cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha3:*:*:*:*:*:* | 2.0.0 alpha3 | Vulnerable | Owlmixin Project |
| cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha4:*:*:*:*:*:* | 2.0.0 alpha4 | Vulnerable | Owlmixin Project |
| cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha5:*:*:*:*:*:* | 2.0.0 alpha5 | Vulnerable | Owlmixin Project |
| cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha6:*:*:*:*:*:* | 2.0.0 alpha6 | Vulnerable | Owlmixin Project |
| cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha7:*:*:*:*:*:* | 2.0.0 alpha7 | Vulnerable | Owlmixin Project |
- cpe:2.3:a:owlmixin_project:owlmixin:*:*:*:*:*:*:*:* Versions before 2.0.0 Vulnerable ·Owlmixin Project
- cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha1:*:*:*:*:*:* Versions 2.0.0 alpha1 Vulnerable ·Owlmixin Project
- cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha10:*:*:*:*:*:* Versions 2.0.0 alpha10 Vulnerable ·Owlmixin Project
- cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha11:*:*:*:*:*:* Versions 2.0.0 alpha11 Vulnerable ·Owlmixin Project
- cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha2:*:*:*:*:*:* Versions 2.0.0 alpha2 Vulnerable ·Owlmixin Project
- cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha3:*:*:*:*:*:* Versions 2.0.0 alpha3 Vulnerable ·Owlmixin Project
- cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha4:*:*:*:*:*:* Versions 2.0.0 alpha4 Vulnerable ·Owlmixin Project
- cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha5:*:*:*:*:*:* Versions 2.0.0 alpha5 Vulnerable ·Owlmixin Project
- cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha6:*:*:*:*:*:* Versions 2.0.0 alpha6 Vulnerable ·Owlmixin Project
- cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha7:*:*:*:*:*:* Versions 2.0.0 alpha7 Vulnerable ·Owlmixin Project
Show 2 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha8:*:*:*:*:*:* | 2.0.0 alpha8 | Vulnerable | Owlmixin Project |
| cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha9:*:*:*:*:*:* | 2.0.0 alpha9 | Vulnerable | Owlmixin Project |
- cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha8:*:*:*:*:*:* Versions 2.0.0 alpha8 Vulnerable ·Owlmixin Project
- cpe:2.3:a:owlmixin_project:owlmixin:2.0.0:alpha9:*:*:*:*:*:* Versions 2.0.0 alpha9 Vulnerable ·Owlmixin Project
Remediation
- Fix · GHSA-ccmq-qvcp-5mrm owlmixin (PyPI) Fixed in 2.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-16618
- 2026-10-03 Alias added: GHSA-ccmq-qvcp-5mrm
References
Exploit 2
Advisory 2
Sources
- CVE-2017-16618 · CVE Program
- CVE-2017-16618 · NVD
- FIRST EPSS
- GHSA-ccmq-qvcp-5mrm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences